summaryrefslogtreecommitdiffstats
path: root/flake.nix
diff options
context:
space:
mode:
authorEelco Dolstra <edolstra@gmail.com>2020-08-19 21:00:57 +0200
committerEelco Dolstra <edolstra@gmail.com>2020-08-19 21:00:57 +0200
commitb4ef3d7078133d6c31c77da45a991bfe2210623a (patch)
treed6ded4cee2975c18e3587ea368dac993491ee4e4 /flake.nix
parentc3e20d8c28ac777fff17c56f57ac8aa28c9272b4 (diff)
Revert "Add a separate manual job"
This reverts commit 5e3ad1dde0a03b3bd094e1d4ecc0f4fc7abdaa5c. Manual generation now depends on the 'nix' command.
Diffstat (limited to 'flake.nix')
-rw-r--r--flake.nix24
1 files changed, 5 insertions, 19 deletions
diff --git a/flake.nix b/flake.nix
index 8f5a3055c..f97197cce 100644
--- a/flake.nix
+++ b/flake.nix
@@ -144,6 +144,11 @@
installFlags = "sysconfdir=$(out)/etc";
+ postInstall = ''
+ mkdir -p $doc/nix-support
+ echo "doc manual $doc/share/doc/nix/manual" >> $doc/nix-support/hydra-build-products
+ '';
+
doInstallCheck = true;
installCheckFlags = "sysconfdir=$(out)/etc";
@@ -210,25 +215,6 @@
# Perl bindings for various platforms.
perlBindings = nixpkgs.lib.genAttrs systems (system: nixpkgsFor.${system}.nix.perl-bindings);
- # Separate build for just the manual.
- manual =
- with nixpkgsFor.x86_64-linux;
- stdenv.mkDerivation {
- name = "nix-manual-${version}";
- src = self;
- buildInputs = [ mdbook ];
- configurePhase = ":";
- buildPhase = ":";
- installPhase =
- ''
- touch Makefile.config
- docdir=$out/share/doc/nix
- make docdir=$docdir doc_generate=yes $docdir/manual/index.html
- mkdir -p $out/nix-support
- echo "doc manual $docdir/manual" >> $out/nix-support/hydra-build-products
- '';
- };
-
# Binary tarball for various platforms, containing a Nix store
# with the closure of 'nix' package, and the second half of
# the installation script.