summaryrefslogtreecommitdiffstats
path: root/flake.nix
diff options
context:
space:
mode:
authorEelco Dolstra <edolstra@gmail.com>2020-07-23 14:55:10 +0200
committerEelco Dolstra <edolstra@gmail.com>2020-07-23 18:27:20 +0200
commit5e3ad1dde0a03b3bd094e1d4ecc0f4fc7abdaa5c (patch)
tree9255dc256ddbf8ca20b855a0dd9b4a08a06e7ca6 /flake.nix
parent69333cb62c0631919ad447629bdd1035df94eb67 (diff)
Add a separate manual job
Diffstat (limited to 'flake.nix')
-rw-r--r--flake.nix24
1 files changed, 19 insertions, 5 deletions
diff --git a/flake.nix b/flake.nix
index cebbdf9d9..f31dc4039 100644
--- a/flake.nix
+++ b/flake.nix
@@ -144,11 +144,6 @@
installFlags = "sysconfdir=$(out)/etc";
- postInstall = ''
- mkdir -p $doc/nix-support
- echo "doc manual $doc/share/doc/nix/manual" >> $doc/nix-support/hydra-build-products
- '';
-
doInstallCheck = true;
installCheckFlags = "sysconfdir=$(out)/etc";
@@ -215,6 +210,25 @@
# Perl bindings for various platforms.
perlBindings = nixpkgs.lib.genAttrs systems (system: nixpkgsFor.${system}.nix.perl-bindings);
+ # Separate build for just the manual.
+ manual =
+ with nixpkgsFor.x86_64-linux;
+ stdenv.mkDerivation {
+ name = "nix-manual-${version}";
+ src = self;
+ buildInputs = [ mdbook ];
+ configurePhase = ":";
+ buildPhase = ":";
+ installPhase =
+ ''
+ touch Makefile.config
+ docdir=$out/share/doc/nix
+ make docdir=$docdir doc_generate=yes $docdir/manual/index.html
+ mkdir -p $out/nix-support
+ echo "doc manual $docdir/manual" >> $out/nix-support/hydra-build-products
+ '';
+ };
+
# Binary tarball for various platforms, containing a Nix store
# with the closure of 'nix' package, and the second half of
# the installation script.