summaryrefslogtreecommitdiffstats
path: root/flake.nix
diff options
context:
space:
mode:
authorMatthew Bauer <mjbauer95@gmail.com>2020-07-30 15:49:52 -0500
committerMatthew Bauer <mjbauer95@gmail.com>2020-07-30 15:53:49 -0500
commit3537670fefab6c65b4b87837112d64931dcda4cf (patch)
treec14eee57272ffb0eb8f307003c840f34e0ac43b1 /flake.nix
parent13ef7a07b9be1dff894e8156a117ee3248241874 (diff)
Only enable static on linux
Diffstat (limited to 'flake.nix')
-rw-r--r--flake.nix10
1 files changed, 6 insertions, 4 deletions
diff --git a/flake.nix b/flake.nix
index 40d779355..20c5089ee 100644
--- a/flake.nix
+++ b/flake.nix
@@ -15,7 +15,8 @@
officialRelease = false;
- systems = [ "x86_64-linux" "i686-linux" "x86_64-darwin" "aarch64-linux" ];
+ linuxSystems = [ "x86_64-linux" "i686-linux" "aarch64-linux" ];
+ systems = linuxSystems ++ [ "x86_64-darwin" ];
forAllSystems = f: nixpkgs.lib.genAttrs systems (system: f system);
@@ -209,7 +210,7 @@
# Binary package for various platforms.
build = nixpkgs.lib.genAttrs systems (system: self.packages.${system}.nix);
- build-static = nixpkgs.lib.genAttrs systems (system: self.packages.${system}.nix-static);
+ build-static = nixpkgs.lib.genAttrs linuxSystems (system: self.packages.${system}.nix-static);
# Perl bindings for various platforms.
perlBindings = nixpkgs.lib.genAttrs systems (system: self.packages.${system}.nix.perl-bindings);
@@ -423,13 +424,14 @@
checks = forAllSystems (system: {
binaryTarball = self.hydraJobs.binaryTarball.${system};
- build-static = self.hydraJobs.build-static.${system};
perlBindings = self.hydraJobs.perlBindings.${system};
+ } // nixpkgs.lib.optionalAttrs (builtins.elem system linuxSystems) {
+ build-static = self.hydraJobs.build-static.${system};
});
packages = forAllSystems (system: {
inherit (nixpkgsFor.${system}) nix;
-
+ } // nixpkgs.lib.optionalAttrs (builtins.elem system linuxSystems) {
nix-static = let
nixpkgs = nixpkgsFor.${system}.pkgsStatic;
in with commonDeps nixpkgs; nixpkgs.stdenv.mkDerivation {