summaryrefslogtreecommitdiffstats
path: root/flake.nix
diff options
context:
space:
mode:
authorEelco Dolstra <edolstra@gmail.com>2019-05-02 21:10:13 +0200
committerEelco Dolstra <edolstra@gmail.com>2019-05-02 21:10:13 +0200
commit2919c496ea10a99d08baffbef485cfb719233b9f (patch)
treece114825d71789122a00e717ca0d1bee2754f7c9 /flake.nix
parent7dcf5b011a0942ecf953f2b607c4c8d0e9e652c7 (diff)
nix dev-shell: Use 'provides.devShell' by default
Thus $ nix dev-shell will now build the 'provides.devShell' attribute from the flake in the current directory. If it doesn't exist, it falls back to 'provides.defaultPackage'.
Diffstat (limited to 'flake.nix')
-rw-r--r--flake.nix5
1 files changed, 5 insertions, 0 deletions
diff --git a/flake.nix b/flake.nix
index 95ec5d952..ab316c7c6 100644
--- a/flake.nix
+++ b/flake.nix
@@ -17,5 +17,10 @@
packages.nix = hydraJobs.build.x86_64-linux;
defaultPackage = packages.nix;
+
+ devShell = import ./shell.nix {
+ nixpkgs = deps.nixpkgs;
+ };
+
};
}