summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorStéphan Kochen <git@stephank.nl>2020-12-04 19:32:35 +0100
committerStéphan Kochen <git@stephank.nl>2020-12-04 19:36:09 +0100
commite20a3ec756c61b076d5fbaea6d976c8ee7fa4c07 (patch)
treecbeeb0f103097b6aa226752628e59afbd9a2b1dc /configure.ac
parent45645b6f3b6c45f20a7bece6da395c3e095aedd0 (diff)
Fix compatibility with newer AWS SDKs
Tested against AWS SDK 1.8.99. Fixes #3201.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac1
1 files changed, 1 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 39306b953..daf378997 100644
--- a/configure.ac
+++ b/configure.ac
@@ -255,6 +255,7 @@ if test -n "$enable_s3"; then
declare -a aws_version_tokens=($(printf '#include <aws/core/VersionConfig.h>\nAWS_SDK_VERSION_STRING' | $CPP $CPPFLAGS - | grep -v '^#.*' | sed 's/"//g' | tr '.' ' '))
AC_DEFINE_UNQUOTED([AWS_VERSION_MAJOR], ${aws_version_tokens@<:@0@:>@}, [Major version of aws-sdk-cpp.])
AC_DEFINE_UNQUOTED([AWS_VERSION_MINOR], ${aws_version_tokens@<:@1@:>@}, [Minor version of aws-sdk-cpp.])
+ AC_DEFINE_UNQUOTED([AWS_VERSION_PATCH], ${aws_version_tokens@<:@2@:>@}, [Patch version of aws-sdk-cpp.])
fi