summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorEelco Dolstra <edolstra@gmail.com>2019-10-30 14:43:09 +0100
committerEelco Dolstra <edolstra@gmail.com>2019-11-06 00:46:37 +0100
commitb874272f7a121a859e7c05abe4d7818bc852eba8 (patch)
tree16607b90584212a006ad54e4c0fe26702624388e /configure.ac
parentd823381c0a82b9b73e08f7f47fedd9258d5daad2 (diff)
Make --enable-gc the default
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 2 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index ebe6d4267..4a6eaac8a 100644
--- a/configure.ac
+++ b/configure.ac
@@ -255,8 +255,8 @@ fi
# Whether to use the Boehm garbage collector.
AC_ARG_ENABLE(gc, AC_HELP_STRING([--enable-gc],
- [enable garbage collection in the Nix expression evaluator (requires Boehm GC) [default=no]]),
- gc=$enableval, gc=no)
+ [enable garbage collection in the Nix expression evaluator (requires Boehm GC) [default=yes]]),
+ gc=$enableval, gc=yes)
if test "$gc" = yes; then
PKG_CHECK_MODULES([BDW_GC], [bdw-gc])
CXXFLAGS="$BDW_GC_CFLAGS $CXXFLAGS"