summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorMatthew Bauer <mjbauer95@gmail.com>2019-10-01 21:07:07 -0400
committerMatthew Bauer <mjbauer95@gmail.com>2019-10-01 21:07:32 -0400
commit74b4737d8f0e1922ef5314a158271acf81cd79f8 (patch)
treed85cde08bce016845b75fe29df00166f00f5b55b /configure.ac
parenta56b51a0ba7b0d6fdff7fd0127a118185b146f4f (diff)
Add libatomic for 32-bit ARM
Fixes #3113
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac5
1 files changed, 5 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index a52830b38..96a2065b1 100644
--- a/configure.ac
+++ b/configure.ac
@@ -157,6 +157,11 @@ AX_BOOST_BASE([1.66], [CXXFLAGS="$BOOST_CPPFLAGS $CXXFLAGS"], [AC_MSG_ERROR([Nix
# ends up with LDFLAGS being empty, so we set it afterwards.
LDFLAGS="$BOOST_LDFLAGS $LDFLAGS"
+# Boost atomic needs GCC libatomic on 32-bit ARM
+case "$host_cpu" in
+ armv5*|armv6*|armv7*) LIBS="-latomic $LIBS"
+esac
+
# Look for OpenSSL, a required dependency.
PKG_CHECK_MODULES([OPENSSL], [libcrypto], [CXXFLAGS="$OPENSSL_CFLAGS $CXXFLAGS"])