summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorEelco Dolstra <edolstra@gmail.com>2019-01-07 23:13:02 +0100
committerGitHub <noreply@github.com>2019-01-07 23:13:02 +0100
commit2fadd30ba4eb9f61b2e7915586d3fc3a27bbabfa (patch)
tree55f701e38e0fdc764c61d100191fe389cc43c77c /configure.ac
parent85488a93ec3b07210339f2b05aa93e970f9ac3be (diff)
parente8b0efdcc9d6329b299937790360cac8b9b256c9 (diff)
Merge pull request #2607 from 0mp/configure.ac-fix
Remove some bashisms from configure.ac
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac17
1 files changed, 11 insertions, 6 deletions
diff --git a/configure.ac b/configure.ac
index 5a2526672..4f00ff014 100644
--- a/configure.ac
+++ b/configure.ac
@@ -212,9 +212,11 @@ AC_SUBST(ENABLE_S3, [$enable_s3])
AC_LANG_POP(C++)
if test -n "$enable_s3"; then
- declare -a aws_version_tokens=($(printf '#include <aws/core/VersionConfig.h>\nAWS_SDK_VERSION_STRING' | $CPP $CPPFLAGS - | grep -v '^#.*' | sed 's/"//g' | tr '.' ' '))
- AC_DEFINE_UNQUOTED([AWS_VERSION_MAJOR], ${aws_version_tokens@<:@0@:>@}, [Major version of aws-sdk-cpp.])
- AC_DEFINE_UNQUOTED([AWS_VERSION_MINOR], ${aws_version_tokens@<:@1@:>@}, [Minor version of aws-sdk-cpp.])
+ aws_version_tokens="$(printf '#include <aws/core/VersionConfig.h>\nAWS_SDK_VERSION_STRING' | $CPP $CPPFLAGS - | grep -v '^#.*' | sed 's/"//g' | tr '.' ' ')"
+ aws_major_version="$(awk -v ver="${aws_version_tokens}" '{print $1}')"
+ aws_minor_version="$(awk -v ver="${aws_version_tokens}" '{print $2}')"
+ AC_DEFINE_UNQUOTED([AWS_VERSION_MAJOR], ${aws_major_version}, [Major version of aws-sdk-cpp.])
+ AC_DEFINE_UNQUOTED([AWS_VERSION_MINOR], ${aws_minor_version}, [Minor version of aws-sdk-cpp.])
fi
@@ -272,9 +274,12 @@ AC_SUBST(sandbox_shell)
test "$prefix" = NONE && prefix=$ac_default_prefix
test "$exec_prefix" = NONE && exec_prefix='${prefix}'
for name in $ac_subst_vars; do
- declare $name="$(eval echo "${!name}")"
- declare $name="$(eval echo "${!name}")"
- declare $name="$(eval echo "${!name}")"
+ for _ in 1 2 3; do
+ if printf '%s' "${name}" | egrep '^[_[:alpha:]][_[:alnum:]]*$'
+ then
+ eval "${name}"="$(eval echo "\${${name}}")"
+ fi
+ done
done
rm -f Makefile.config