summaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py34
1 files changed, 34 insertions, 0 deletions
diff --git a/setup.py b/setup.py
new file mode 100644
index 0000000..db45f95
--- /dev/null
+++ b/setup.py
@@ -0,0 +1,34 @@
+from setuptools import setup
+
+setup(
+ name='ngxtop',
+ version='0.0.1',
+ description='Real-time metrics for nginx server',
+ long_description=open('README.rst').read(),
+ license='MIT',
+
+ url='https://github.com/lebinh/ngxtop',
+ author='Binh Le',
+ author_email='lebinh.it@gmail.com',
+
+ classifiers=[
+ 'Development Status :: 4 - Beta',
+ 'License :: OSI Approved :: MIT License',
+ 'Environment :: Console',
+ 'Intended Audience :: Developers',
+ 'Intended Audience :: System Administrators',
+ 'Programming Language :: Python :: 2',
+ 'Programming Language :: Python :: 2.6',
+ 'Programming Language :: Python :: 2.7',
+ ],
+ keywords='cli monitoring nginx system',
+
+ packages=['ngxtop'],
+ install_requires=['docopt', 'tabulate'],
+
+ entry_points={
+ 'console_scripts': [
+ 'ngxtop = ngxtop.ngxtop:main',
+ ],
+ },
+)