summaryrefslogtreecommitdiffstats
path: root/contrib/debian/rules
diff options
context:
space:
mode:
Diffstat (limited to 'contrib/debian/rules')
-rwxr-xr-xcontrib/debian/rules8
1 files changed, 8 insertions, 0 deletions
diff --git a/contrib/debian/rules b/contrib/debian/rules
index f36e995fc8..57e861c218 100755
--- a/contrib/debian/rules
+++ b/contrib/debian/rules
@@ -75,6 +75,10 @@ override_dh_install:
mkdir -p "$(TOP)/var/cache/netdata"
mkdir -p "$(TOP)/var/run/netdata"
+ # Copy the updater script
+ #
+ cp -v packaging/installer/netdata-updater.sh $(TOP)/usr/libexec/netdata/netdata-updater.sh
+
# Move files that local user shouldn't be editing to /usr/share/netdata
#
mkdir -p "$(TOP)/usr/share/netdata/www"
@@ -108,6 +112,10 @@ override_dh_installdocs:
override_dh_fixperms:
dh_fixperms
+ # Updater script should be executable
+ #
+ chmod 0755 $(TOP)/usr/libexec/netdata/netdata-updater.sh
+
# apps.plugin should only be runnable by the netdata user. It will be
# given extra capabilities in the postinst script.
#