summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt20
1 files changed, 7 insertions, 13 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index fc7e47fbd0..e0c114ab4b 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -348,11 +348,11 @@ ENDIF()
# Detect ml dependencies
file(STRINGS "${CMAKE_SOURCE_DIR}/config.h" DEFINE_ENABLE_ML REGEX "^#define ENABLE_ML 1$")
IF(DEFINE_ENABLE_ML MATCHES ".+" AND
- EXISTS "${CMAKE_SOURCE_DIR}/ml/kmeans/dlib/dlib/all/source.cpp" AND
+ EXISTS "${CMAKE_SOURCE_DIR}/ml/dlib/dlib/all/source.cpp" AND
EXISTS "${CMAKE_SOURCE_DIR}/ml/json/single_include/nlohmann/json.hpp")
set(ENABLE_ML True)
list(APPEND NETDATA_COMMON_CFLAGS "-DDLIB_NO_GUI_SUPPORT")
- list(APPEND NETDATA_COMMON_INCLUDE_DIRS "ml/kmeans/dlib")
+ list(APPEND NETDATA_COMMON_INCLUDE_DIRS "ml/dlib")
ELSE()
set(ENABLE_ML False)
ENDIF()
@@ -1025,24 +1025,18 @@ set(ML_FILES
IF(ENABLE_ML)
list(APPEND ML_FILES
- ml/BitBufferCounter.h
- ml/BitBufferCounter.cc
- ml/BitRateWindow.h
- ml/BitRateWindow.cc
ml/Config.h
ml/Config.cc
- ml/Database.h
- ml/Database.cc
ml/Dimension.cc
ml/Dimension.h
ml/Host.h
ml/Host.cc
ml/Query.h
- ml/kmeans/KMeans.h
- ml/kmeans/KMeans.cc
- ml/kmeans/SamplesBuffer.h
- ml/kmeans/SamplesBuffer.cc
- ml/kmeans/dlib/dlib/all/source.cpp
+ ml/KMeans.h
+ ml/KMeans.cc
+ ml/SamplesBuffer.h
+ ml/SamplesBuffer.cc
+ ml/dlib/dlib/all/source.cpp
ml/json/single_include/nlohmann/json.hpp
ml/ml.cc
ml/ml-private.h