summaryrefslogtreecommitdiffstats
path: root/web/Makefile.am
diff options
context:
space:
mode:
authorAustin S. Hemmelgarn <austin@netdata.cloud>2020-04-24 07:11:30 -0400
committerGitHub <noreply@github.com>2020-04-24 07:11:30 -0400
commitd34f3ce1fc3fe6bdd46002311bd41a628a79717b (patch)
tree06d2026aac064b52843b7f29d7c0cd853bc82c02 /web/Makefile.am
parent8eb9278aa8b9d57b09e74266d1cc2d4b2ffa6f69 (diff)
Use a prefix for the old dashboard. (#8752)
* Use a prefix for the old dashboard. This switches the code for handling of the new React dashboard to use a prefix for accessing the old dashboard instead of relying on a switching script to handle selecting the desired dashboard implementation. It also adds proper support to the packaging code to bundle the React dashboard. * Fixed typos in web/gui/Makefile.am. * Tidy up prefixed dashboard. This is based on discussion with cakrit about how to handle this more sanely. * use /old suffix for streamed nodes links in dropdown menu * fix fetching dynamic vendor files with /old suffix Co-authored-by: Jacek Kolasa <jacek.kolasa@gmail.com>
Diffstat (limited to 'web/Makefile.am')
-rw-r--r--web/Makefile.am13
1 files changed, 0 insertions, 13 deletions
diff --git a/web/Makefile.am b/web/Makefile.am
index 0c8b0332c3..ccaccd764c 100644
--- a/web/Makefile.am
+++ b/web/Makefile.am
@@ -9,20 +9,8 @@ SUBDIRS = \
server \
$(NULL)
-CLEANFILES = \
- netdata-switch-dashboard.sh \
- $(NULL)
-
usersslconfigdir=$(configdir)/ssl
-include $(top_srcdir)/build/subst.inc
-SUFFIXES = .in
-
-scriptsdir=${prefix}/libexec/netdata
-scripts_SCRIPTS = \
- netdata-switch-dashboard.sh \
- $(NULL)
-
# Explicitly install directories to avoid permission issues due to umask
install-exec-local:
$(INSTALL) -d $(DESTDIR)$(usersslconfigdir)
@@ -31,5 +19,4 @@ dist_noinst_DATA = \
README.md \
gui/confluence/README.md \
gui/custom/README.md \
- netdata-switch-dashboard.sh.in \
$(NULL)