summaryrefslogtreecommitdiffstats
path: root/web/Makefile.am
diff options
context:
space:
mode:
authorPhilip Whineray <phil@firehol.org>2016-04-04 22:15:27 +0100
committerPhilip Whineray <phil@firehol.org>2016-04-04 22:25:56 +0100
commit2a694530e904815d10ad843f40f3d9f5670915b3 (patch)
tree55100254ba0c3f4f8cac449edc98f0b3338038d9 /web/Makefile.am
parent514b7bb46bc3919e7dd7c4a66682514690d3fd7d (diff)
Add a generated version.txt containing commit id
Diffstat (limited to 'web/Makefile.am')
-rw-r--r--web/Makefile.am5
1 files changed, 5 insertions, 0 deletions
diff --git a/web/Makefile.am b/web/Makefile.am
index 56fe879238..a437f50af2 100644
--- a/web/Makefile.am
+++ b/web/Makefile.am
@@ -16,6 +16,7 @@ dist_web_DATA = \
favicon.ico \
netdata-swagger.yaml \
netdata-swagger.json \
+ version.txt \
$(NULL)
webolddir=$(webdir)/old
@@ -89,4 +90,8 @@ dist_webimages_DATA = \
images/seo-performance-multi-size.icns \
$(NULL)
+version.txt:
+ git log -n 1 | grep ^commit\ | cut -d " " -f 2 > version.txt.tmp
+ mv version.txt.tmp version.txt
+.PHONY: version.txt