summaryrefslogtreecommitdiffstats
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorVladimir Kobal <vlad@prokk.net>2016-12-26 19:34:23 +0200
committerVladimir Kobal <vlad@prokk.net>2016-12-26 19:44:14 +0200
commit54a793a748bd73d56abc93ea973476490e25d4a2 (patch)
tree3896d886d691100f34a47d7ec02a5e71b4857c95 /src/Makefile.am
parent7375c9fda037fe6882fa706c56e907ab25c8afea (diff)
Separate macOS plugin
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am8
1 files changed, 8 insertions, 0 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index c2918744a2..8df6b61fcf 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -67,6 +67,13 @@ netdata_SOURCES += \
freebsd_sysctl.c \
$(NULL)
else
+if MACOS
+netdata_SOURCES += \
+ plugin_macos.c plugin_macos.h \
+ macos_sysctl.c \
+ macos_mach_smi.c \
+ $(NULL)
+else
netdata_SOURCES += \
plugin_proc.c plugin_proc.h \
proc_diskstats.c \
@@ -91,6 +98,7 @@ netdata_SOURCES += \
sys_kernel_mm_ksm.c \
$(NULL)
endif
+endif
netdata_LDADD = \
$(OPTIONAL_MATH_LIBS) \