summaryrefslogtreecommitdiffstats
path: root/contrib/debian
diff options
context:
space:
mode:
authorAustin S. Hemmelgarn <austin@netdata.cloud>2022-02-18 10:08:38 -0500
committerGitHub <noreply@github.com>2022-02-18 10:08:38 -0500
commitda7f215ad6c98cbf54ab93dbc1d2457ac01dbb08 (patch)
treee8a02e870c9a45a8ba2e45614d25254b1cea7a1f /contrib/debian
parentf3e8c077cfdaebd8073927803a2a4707a302d26a (diff)
Overhaul handling of auto-updates in the installer code. (#12076)
* Bundle updater script in native packages. * Move code for enabling/disabling auto-updates to netdata-updater.sh This lets us handle the logic sanely from the kickstart script regardless of the install method, and allows users to more reliably toggle auto-updates themselves without having to understand what is being done. * Add proper case-agnosticism to auto-update type selection. * Move auto-updater handling code to kickstart script. * Properly handle running against an older source tree. * First part of updater docmentation updates. * Fixed handling of updater in DEB packages. * Further documentation updates. * Minor typo fixes.
Diffstat (limited to 'contrib/debian')
-rwxr-xr-xcontrib/debian/rules8
1 files changed, 8 insertions, 0 deletions
diff --git a/contrib/debian/rules b/contrib/debian/rules
index f36e995fc8..57e861c218 100755
--- a/contrib/debian/rules
+++ b/contrib/debian/rules
@@ -75,6 +75,10 @@ override_dh_install:
mkdir -p "$(TOP)/var/cache/netdata"
mkdir -p "$(TOP)/var/run/netdata"
+ # Copy the updater script
+ #
+ cp -v packaging/installer/netdata-updater.sh $(TOP)/usr/libexec/netdata/netdata-updater.sh
+
# Move files that local user shouldn't be editing to /usr/share/netdata
#
mkdir -p "$(TOP)/usr/share/netdata/www"
@@ -108,6 +112,10 @@ override_dh_installdocs:
override_dh_fixperms:
dh_fixperms
+ # Updater script should be executable
+ #
+ chmod 0755 $(TOP)/usr/libexec/netdata/netdata-updater.sh
+
# apps.plugin should only be runnable by the netdata user. It will be
# given extra capabilities in the postinst script.
#