summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorvkalintiris <vasilis@netdata.cloud>2023-03-10 12:20:40 +0200
committerGitHub <noreply@github.com>2023-03-10 12:20:40 +0200
commit37a06960f90c046f21c125c2b4265713da04f851 (patch)
tree54ed00a16dffb010a10242507cadb7140b28975b /configure.ac
parenta0652435f0dea126b6603a2467d912ca8a677e36 (diff)
Refactor ML code. (#14659)
* Refactor ML code. This commit introduces only non-functional changes. Originally, the C++ code exposed C functions to be called from the rest of the agent. When we migrated from C++ to C, we did not eliminate these wrapper functions to make the PR easier to understand and keep the total LOC low. This commit removes the wrapper functions and "reclaims" the `ml_` prefix that we used for the public API of the old implementation. Also, the nlohmann Json library has been removed and its functionality was replaced with the equivalent Json functionality that we added in libnetdata's BUFFERs. * Remove missing headers from build systems. * Fix CMake build. * rrddim_free is outside of rrd "internals" now.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 5971697f63..9b9143f7fb 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1140,7 +1140,7 @@ fi
# Check if submodules have not been fetched. Fail if ML was explicitly requested.
AC_MSG_CHECKING([if git submodules are present for machine learning functionality])
-if test -f "ml/dlib/dlib/all/source.cpp" -a -f "ml/json/single_include/nlohmann/json.hpp"; then
+if test -f "ml/dlib/dlib/all/source.cpp"; then
AC_MSG_RESULT([yes])
have_ml_submodules="yes"
else