summaryrefslogtreecommitdiffstats
path: root/collectors/python.d.plugin/Makefile.am
diff options
context:
space:
mode:
authorIlya Mashchenko <ilyamaschenko@gmail.com>2019-02-28 13:35:15 +0300
committerGitHub <noreply@github.com>2019-02-28 13:35:15 +0300
commit97a4bf8dc11e5e71c28e31221651aee34e409cf5 (patch)
tree07caad01c1fd2a4877cb7dcdf98118490f140cab /collectors/python.d.plugin/Makefile.am
parent7297c45ffb9668cd8f59e55d48455aad562ee87a (diff)
oracledb py module (#5421)
<!-- Describe the change in summary section, including rationale and degin decisions. Include "Fixes #nnn" if you are fixing an existing issue. In "Component Name" section write which component is changed in this PR. This will help us review your PR quicker. If you have more information you want to add, write them in "Additional Information" section. This is usually used to help others understand your motivation behind this change. A step-by-step reproduction of the problem is helpful if there is no related issue. --> ##### Summary Fixes: #1996 ##### Component Name python.d.plugin oracledb module ##### Additional Information #### Used queries: - [system metrics]: ```sql SELECT metric_name, value FROM gv$sysmetric ORDER BY begin_time ``` <details><summary>collected metrics</summary> <p> | name| |---| | average_active_sessions | | session_count | | session_limit_percent | | logons_per_sec | | physical_reads_per_sec | | physical_writes_per_sec | | disk_sort_per_sec | | long_table_scans_per_sec | | database_wait_time_ratio | | shared_pool_free_percent | | memory_sorts_ratio | | sql_service_response_time | | user_rollbacks_per_sec | | enqueue_timeouts_per_sec | | buffer_cache_hit_ratio | | cursor_cache_hit_ratio | | library_cache_hit_ratio | | row_cache_hit_ratio | | global_cache_blocks_corrupted | | global_cache_blocks_lost | </p> </details> </br> - [tablespace] ```sql SELECT m.tablespace_name, m.used_space * t.block_size AS used_bytes, m.tablespace_size * t.block_size AS max_bytes, m.used_percent FROM dba_tablespace_usage_metrics m JOIN dba_tablespaces t ON m.tablespace_name = t.tablespace_name ``` <details><summary>collected metrics</summary> <p> | name| |---| | tablespace_size | | tablespace_used | | tablespace_used_in_percent | </p> </details> </br> - [activities count] ```sql SELECT name, value FROM v$sysstat WHERE name IN ( 'parse count (total)', 'execute count', 'user commits', 'user rollbacks' ) ``` <details><summary>collected metrics</summary> <p> | name| |---| | activity_parse_count | | activity_execute_count | | activity_user_commits | | activity_user_rollbacks | </p> </details> </br> - wait time ```sql SELECT n.wait_class, round(m.time_waited / m.INTSIZE_CSEC, 3) FROM v$waitclassmetric m, v$system_wait_class n WHERE m.wait_class_id = n.wait_class_id AND n.wait_class != 'Idle' ```
Diffstat (limited to 'collectors/python.d.plugin/Makefile.am')
-rw-r--r--collectors/python.d.plugin/Makefile.am1
1 files changed, 1 insertions, 0 deletions
diff --git a/collectors/python.d.plugin/Makefile.am b/collectors/python.d.plugin/Makefile.am
index 3599d9c9fa..b6bdbcc4f8 100644
--- a/collectors/python.d.plugin/Makefile.am
+++ b/collectors/python.d.plugin/Makefile.am
@@ -78,6 +78,7 @@ include nsd/Makefile.inc
include ntpd/Makefile.inc
include ovpn_status_log/Makefile.inc
include openldap/Makefile.inc
+include oracledb/Makefile.inc
include phpfpm/Makefile.inc
include portcheck/Makefile.inc
include postfix/Makefile.inc