summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorVladimir Kobal <vlad@prokk.net>2020-04-06 09:26:25 +0300
committerGitHub <noreply@github.com>2020-04-06 09:26:25 +0300
commitebbce7c7773a886d222dbaa60d098b6c25150f69 (patch)
tree03848706164fba421a72c9bedf25f421ffdafa25 /Makefile.am
parent50209f1971280324b0e692ac01bf45e809874856 (diff)
Prometheus web api connector (#8540)
* Fix the Prometheus web API code in the exporting engine * Rename connector types * Remove the conditional compilation of the exporting engine * Use labels instead of tags * Fix the exporter configuration * Document functions * Add unit tests
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am30
1 files changed, 4 insertions, 26 deletions
diff --git a/Makefile.am b/Makefile.am
index e4e240cbda..28debf3999 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -573,6 +573,7 @@ NETDATA_FILES = \
$(LIBNETDATA_FILES) \
$(API_PLUGIN_FILES) \
$(BACKENDS_PLUGIN_FILES) \
+ $(EXPORTING_ENGINE_FILES) \
$(CHECKS_PLUGIN_FILES) \
$(HEALTH_PLUGIN_FILES) \
$(IDLEJITTER_PLUGIN_FILES) \
@@ -608,12 +609,6 @@ if LINUX
endif
-if ENABLE_EXPORTING
- NETDATA_FILES += \
- $(EXPORTING_ENGINE_FILES) \
- $(NULL)
-endif
-
NETDATA_COMMON_LIBS = \
$(OPTIONAL_MATH_LIBS) \
$(OPTIONAL_ZLIB_LIBS) \
@@ -745,23 +740,13 @@ if ENABLE_PLUGIN_SLABINFO
$(NULL)
endif
-if ENABLE_EXPORTING
-if ENABLE_BACKEND_KINESIS
- netdata_SOURCES += $(KINESIS_EXPORTING_FILES)
- netdata_LDADD += $(OPTIONAL_KINESIS_LIBS)
-endif
-endif
-
if ENABLE_BACKEND_KINESIS
- netdata_SOURCES += $(KINESIS_BACKEND_FILES)
+ netdata_SOURCES += $(KINESIS_BACKEND_FILES) $(KINESIS_EXPORTING_FILES)
netdata_LDADD += $(OPTIONAL_KINESIS_LIBS)
endif
if ENABLE_BACKEND_PROMETHEUS_REMOTE_WRITE
-if ENABLE_EXPORTING
- netdata_SOURCES += $(PROMETHEUS_REMOTE_WRITE_EXPORTING_FILES)
-endif
- netdata_SOURCES += $(PROMETHEUS_REMOTE_WRITE_BACKEND_FILES)
+ netdata_SOURCES += $(PROMETHEUS_REMOTE_WRITE_BACKEND_FILES) $(PROMETHEUS_REMOTE_WRITE_EXPORTING_FILES)
netdata_LDADD += $(OPTIONAL_PROMETHEUS_REMOTE_WRITE_LIBS)
BUILT_SOURCES = \
exporting/prometheus/remote_write/remote_write.pb.cc \
@@ -775,15 +760,8 @@ exporting/prometheus/remote_write/remote_write.pb.h: exporting/prometheus/remote
endif
-if ENABLE_EXPORTING
-if ENABLE_BACKEND_MONGODB
- netdata_SOURCES += $(MONGODB_EXPORTING_FILES)
- netdata_LDADD += $(OPTIONAL_MONGOC_LIBS)
-endif
-endif
-
if ENABLE_BACKEND_MONGODB
- netdata_SOURCES += $(MONGODB_BACKEND_FILES)
+ netdata_SOURCES += $(MONGODB_BACKEND_FILES) $(MONGODB_EXPORTING_FILES)
netdata_LDADD += $(OPTIONAL_MONGOC_LIBS)
endif