summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorPaweł Krupa <pawel@krupa.net.pl>2018-09-26 12:46:28 +0200
committerGitHub <noreply@github.com>2018-09-26 12:46:28 +0200
commitc1b02322653f8474c6dc077f33f016d68f54406b (patch)
treed79203405b885b533db58455a77a344c6de98a65 /Makefile.am
parent465d375c5096421254c6e331394bf6d69ab36db9 (diff)
reproducible build system (#4294)
- Move `m4` dir to `build/m4` to clean TLD - create `build/build.sh` script which builds netdata in docker container - create `build/Dockerfile` which creates reproducible build environment - exclude `.lgtm.yml` from final package - use `.tar.gz` package in `netdata.spec.in` as `*.xz` and `*.bz2` will be removed due to #3913 What it does is simple, you don't need any libraries installed on host to build netdata as they are provided inside a container.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am31
1 files changed, 17 insertions, 14 deletions
diff --git a/Makefile.am b/Makefile.am
index e3881a614f..89e1ce3a28 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -2,8 +2,8 @@
# Copyright (C) 2015 Alon Bar-Lev <alon.barlev@gmail.com>
# SPDX-License-Identifier: GPL-3.0+
#
-AUTOMAKE_OPTIONS=foreign dist-bzip2 dist-xz 1.10
-ACLOCAL_AMFLAGS = -I m4
+AUTOMAKE_OPTIONS=foreign 1.10
+ACLOCAL_AMFLAGS = -I build/m4
MAINTAINERCLEANFILES= \
config.log config.status \
@@ -24,19 +24,22 @@ EXTRA_DIST = \
.csslintrc \
.eslintignore \
.eslintrc \
+ .lgtm.yml \
.travis \
- m4/jemalloc.m4 \
- m4/ax_c___atomic.m4 \
- m4/ax_check_enable_debug.m4 \
- m4/ax_c_mallinfo.m4 \
- m4/ax_gcc_func_attribute.m4 \
- m4/ax_check_compile_flag.m4 \
- m4/ax_c_statement_expressions.m4 \
- m4/ax_pthread.m4 \
- m4/ax_c_lto.m4 \
- m4/ax_c_mallopt.m4 \
- m4/tcmalloc.m4 \
- m4/ax_c__generic.m4 \
+ build/build.sh
+ build/Dockerfile
+ build/m4/jemalloc.m4 \
+ build/m4/ax_c___atomic.m4 \
+ build/m4/ax_check_enable_debug.m4 \
+ build/m4/ax_c_mallinfo.m4 \
+ build/m4/ax_gcc_func_attribute.m4 \
+ build/m4/ax_check_compile_flag.m4 \
+ build/m4/ax_c_statement_expressions.m4 \
+ build/m4/ax_pthread.m4 \
+ build/m4/ax_c_lto.m4 \
+ build/m4/ax_c_mallopt.m4 \
+ build/m4/tcmalloc.m4 \
+ build/m4/ax_c__generic.m4 \
README.md \
CONTRIBUTORS.md \
LICENSE \