summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorVladimir Kobal <vlad@prokk.net>2020-05-14 10:54:23 +0300
committerGitHub <noreply@github.com>2020-05-14 10:54:23 +0300
commitb5f8c224a9636c071fc474634380b4a93ea21c28 (patch)
tree0676b067283d6c1fe46f091a7bba6afc6a362bc3 /Makefile.am
parentb8fce8d15bd9f97e8748305ca8f839a6de889199 (diff)
Add a Google Cloud Pub/Sub connector to the exporting engine (#8855)
* Implement formatters * Add specific configuration options * Add the connector to the Autotools and CMake configuration * Initialize a connector instance * Publish netdata metrics * Fix internal stats * Add unit tests * Improve the documentation
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am22
1 files changed, 22 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 298d4550bf..c26b93ae86 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -531,6 +531,13 @@ KINESIS_EXPORTING_FILES = \
exporting/aws_kinesis/aws_kinesis_put_record.h \
$(NULL)
+PUBSUB_EXPORTING_FILES = \
+ exporting/pubsub/pubsub.c \
+ exporting/pubsub/pubsub.h \
+ exporting/pubsub/pubsub_publish.cc \
+ exporting/pubsub/pubsub_publish.h \
+ $(NULL)
+
MONGODB_EXPORTING_FILES = \
exporting/mongodb/mongodb.c \
exporting/mongodb/mongodb.h \
@@ -752,6 +759,11 @@ if ENABLE_BACKEND_KINESIS
netdata_LDADD += $(OPTIONAL_KINESIS_LIBS)
endif
+if ENABLE_EXPORTING_PUBSUB
+ netdata_SOURCES += $(PUBSUB_EXPORTING_FILES)
+ netdata_LDADD += $(OPTIONAL_PUBSUB_LIBS)
+endif
+
if ENABLE_BACKEND_PROMETHEUS_REMOTE_WRITE
netdata_SOURCES += $(PROMETHEUS_REMOTE_WRITE_BACKEND_FILES) $(PROMETHEUS_REMOTE_WRITE_EXPORTING_FILES)
netdata_LDADD += $(OPTIONAL_PROMETHEUS_REMOTE_WRITE_LIBS)
@@ -906,6 +918,16 @@ if ENABLE_BACKEND_KINESIS
-Wl,--wrap=kinesis_get_result \
$(NULL)
endif
+if ENABLE_EXPORTING_PUBSUB
+ exporting_tests_exporting_engine_testdriver_SOURCES += $(PUBSUB_EXPORTING_FILES)
+ exporting_tests_exporting_engine_testdriver_LDADD += $(OPTIONAL_PUBSUB_LIBS)
+ exporting_tests_exporting_engine_testdriver_LDFLAGS += \
+ -Wl,--wrap=pubsub_init \
+ -Wl,--wrap=pubsub_add_message \
+ -Wl,--wrap=pubsub_publish \
+ -Wl,--wrap=pubsub_get_result \
+ $(NULL)
+endif
if ENABLE_BACKEND_MONGODB
exporting_tests_exporting_engine_testdriver_SOURCES += $(MONGODB_EXPORTING_FILES)
exporting_tests_exporting_engine_testdriver_LDADD += $(OPTIONAL_MONGOC_LIBS)