summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorCosta Tsaousis <costa@netdata.cloud>2023-07-06 17:19:15 +0300
committerGitHub <noreply@github.com>2023-07-06 17:19:15 +0300
commit9af8a73e255ee66c89175844eb2f3759672e5cc2 (patch)
tree7c3ce3effa90ada46a42351a240d2fc2eecfcac6 /Makefile.am
parent4f5228e65463cf680d2ec3fedaf71c813d69309b (diff)
local-listener using libnetdata (#15319)
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am2
1 files changed, 2 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index c6f55d4dc9..26e345bbf4 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -283,6 +283,7 @@ CGROUP_NETWORK_FILES = \
LOCAL_LISTENERS_FILES = \
collectors/plugins.d/local_listeners.c \
+ $(LIBNETDATA_FILES) \
$(NULL)
DISKSPACE_PLUGIN_FILES = \
@@ -1213,6 +1214,7 @@ if ENABLE_PLUGIN_LOCAL_LISTENERS
plugins_PROGRAMS += local-listeners
local_listeners_SOURCES = $(LOCAL_LISTENERS_FILES)
local_listeners_LDADD = \
+ $(NETDATA_COMMON_LIBS) \
$(NULL)
endif