summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorCosta Tsaousis <costa@tsaousis.gr>2018-10-27 19:44:27 +0300
committerGitHub <noreply@github.com>2018-10-27 19:44:27 +0300
commit798c141c49ee85bddc8f48f25d2cb593ec96da07 (patch)
tree61daf51c5c18f625ca2541b9abe762ad27f13b85 /Makefile.am
parentbcdfedbe8215fdf461b61900eba2a9de4be6c0b8 (diff)
Split the API formatters in modules (#4504)
* split all API formatters in modules * added markdown formatting * updated csv readme * updated csv readme * more documentation * added more documentation * updated documentation * fixed typo * fixed typo
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am18
1 files changed, 16 insertions, 2 deletions
diff --git a/Makefile.am b/Makefile.am
index 45be88f5ad..c7fa48c6bd 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -311,8 +311,22 @@ API_PLUGIN_FILES = \
web/api/queries/stddev/stddev.h \
web/api/queries/sum/sum.c \
web/api/queries/sum/sum.h \
- web/api/rrd2json.c \
- web/api/rrd2json.h \
+ web/api/formatters/rrd2json.c \
+ web/api/formatters/rrd2json.h \
+ web/api/formatters/csv/csv.c \
+ web/api/formatters/csv/csv.h \
+ web/api/formatters/json/json.c \
+ web/api/formatters/json/json.h \
+ web/api/formatters/ssv/ssv.c \
+ web/api/formatters/ssv/ssv.h \
+ web/api/formatters/value/value.c \
+ web/api/formatters/value/value.h \
+ web/api/formatters/json_wrapper.c \
+ web/api/formatters/json_wrapper.h \
+ web/api/formatters/charts2json.c \
+ web/api/formatters/charts2json.h \
+ web/api/formatters/rrdset2json.c \
+ web/api/formatters/rrdset2json.h \
web/api/web_api_v1.c \
web/api/web_api_v1.h \
$(NULL)