summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorVladimir Kobal <vlad@prokk.net>2019-08-14 11:03:40 +0300
committerGitHub <noreply@github.com>2019-08-14 11:03:40 +0300
commit6262597923df989d4b9fc216f1645b006059da19 (patch)
tree8a82c7e0fe4a56120ef29ef96bd40f80685dba1c /Makefile.am
parentf1285715cd6615ac94a3eb691ab346c9ef09ec56 (diff)
Add MongoDB backend (#6524)
* Add mongodb backend skeleton * Send data to the backend * Send metrics as separate JSON documents * Add a configuration file * Send all metrics in a batch * Update the documentation * Free configuration strings on exit * Make socket timeout configurable
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am10
1 files changed, 10 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 7cff5ff559..fa12a757d2 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -458,6 +458,11 @@ PROMETHEUS_REMOTE_WRITE_BACKEND_FILES = \
backends/prometheus/remote_write/remote_write.proto \
$(NULL)
+MONGODB_BACKEND_FILES = \
+ backends/mongodb/mongodb.c \
+ backends/mongodb/mongodb.h \
+ $(NULL)
+
DAEMON_FILES = \
daemon/common.c \
daemon/common.h \
@@ -615,3 +620,8 @@ backends/prometheus/remote_write/remote_write.pb.h: backends/prometheus/remote_w
$(PROTOC) --proto_path=$(srcdir) --cpp_out=$(builddir) $^
endif
+
+if ENABLE_BACKEND_MONGODB
+ netdata_SOURCES += $(MONGODB_BACKEND_FILES)
+ netdata_LDADD += $(OPTIONAL_MONGOC_LIBS)
+endif