summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorAustin S. Hemmelgarn <austin@netdata.cloud>2020-09-16 07:03:27 -0400
committerGitHub <noreply@github.com>2020-09-16 07:03:27 -0400
commit5f3a7224abe61ed0105d3d681b3d2b82aa61e2eb (patch)
treedc11b4306870c01e2824c173a69f5473585552c9 /Makefile.am
parenta1b997f7bcc5dc8de93473abc27d413035c2d47e (diff)
Added a way to get build configuration info from the agent. (#9913)
* Add a way to get build configuration info from the agent. This adds a new option to the `-W` switch called 'buildinfo'. When invoked with this argument, Netdata will print it's version, the configure options, and a list of optional features and whether they are enabled or not. This is intended to serve three purposes: * It allows developers to more quickly get an idea of how Netdata was built when triaging bug reports. * It provides an easier way to validate changes to the build system that affect optional features during the development cycle. * It provides an easier way to build CI workflows that validate that building under a given set of constraints results in a feature being enabled or not. The actual implementation is a bit large but overall exceedingly simple, consisting of a set of preprocessor directives to extract optional feature state information from config.h and then a series of printf() calls to actually report this info (which should end up optimized by smart compilers due to all the arguments being compile-time constants). * Added zlib to optional libraries. * Added remaining optional plugins to buildinfo output. * Changed formatting to be more human friendly. * Add remaining optional libraries. * Fix up formatting to be even more human friendly. * Fix typo in buildinfo output. * Remove unused variable. * Fixed spelling of config.h option name. * Update daemon/buildinfo.c Co-authored-by: Markos Fountoulakis <44345837+mfundul@users.noreply.github.com> * Fix option name mismatch for libcrypto. * Update daemon/buildinfo.c Co-authored-by: Markos Fountoulakis <44345837+mfundul@users.noreply.github.com> Co-authored-by: Markos Fountoulakis <44345837+mfundul@users.noreply.github.com>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am2
1 files changed, 2 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 7e4dca74ac..3e232ca3b8 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -618,6 +618,8 @@ MONGODB_BACKEND_FILES = \
$(NULL)
DAEMON_FILES = \
+ daemon/buildinfo.c \
+ daemon/buildinfo.h \
daemon/common.c \
daemon/common.h \
daemon/daemon.c \