summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorCosta Tsaousis <costa@netdata.cloud>2023-07-10 18:02:02 +0300
committerGitHub <noreply@github.com>2023-07-10 18:02:02 +0300
commit5943203a66b6b98e9619c8c2825aad517b209b1c (patch)
treed54cdc2a6ce11957cb6edd1184240502cba260e9 /Makefile.am
parentafb8095ec0acc393eef998952fbf2715880b4af1 (diff)
bearer authorization API (#15321)
* bearer authorization API - untested * add machine guid to bearer token response * removed REGISTRY_URL and replaced it with STRING * eliminate url pointer from registry_machine_url * remove registry_url counters from registry * Revert "eliminate url pointer from registry_machine_url" This reverts commit 79eff56f77d12a9f840f1b30040e4123e3d9a7a2. * registry machine urls are now a double linked list * registry machine urls are now using aral * all registry objects now use aral * strings now have 64 partitions and use R/W spinlock * string to 128 partitions * fix macro without internal checks * registry now uses the bearer token when the cookie is not there * api/v1/registry sends back all nodes on each host * registry option to use mmap; optimization of registry structures * do not index the terminator byte in strings; use 256 string partitions * registry loading optimization * convert person urls to double linked list to save memory * re-organize items loading and make sure person urls are always available as machine urls too * disable registry mmap by default * keep track of all machine guids and their URLs, even if the cookie cannot be set * fix bearer parsing
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am2
1 files changed, 0 insertions, 2 deletions
diff --git a/Makefile.am b/Makefile.am
index 26e345bbf4..5998a7bea0 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -661,8 +661,6 @@ REGISTRY_PLUGIN_FILES = \
registry/registry_machine.h \
registry/registry_person.c \
registry/registry_person.h \
- registry/registry_url.c \
- registry/registry_url.h \
$(NULL)
STATSD_PLUGIN_FILES = \