summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorStelios Fragkakis <52996999+stelfrag@users.noreply.github.com>2020-05-25 20:25:08 +0300
committerGitHub <noreply@github.com>2020-05-25 20:25:08 +0300
commit570d5253f53b46ce59b3fd93a53b15f56f946038 (patch)
tree490cda44451f87f1dc46457f381cbc8296238ee4 /Makefile.am
parent4fb41597da6961813679c1b795793600ddc0a402 (diff)
Implement new incremental parser (#9074)
Implemented a new parser for the pluginsd language
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am9
1 files changed, 9 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index a60280e2a3..cfbc97dac4 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -105,6 +105,7 @@ SUBDIRS += \
streaming \
web \
claim \
+ parser \
aclk \
spawn \
$(NULL)
@@ -325,6 +326,8 @@ MACOS_PLUGIN_FILES = \
PLUGINSD_PLUGIN_FILES = \
collectors/plugins.d/plugins_d.c \
collectors/plugins.d/plugins_d.h \
+ collectors/plugins.d/pluginsd_parser.c \
+ collectors/plugins.d/pluginsd_parser.h \
$(NULL)
RRD_PLUGIN_FILES = \
@@ -472,6 +475,11 @@ CLAIM_FILES = \
claim/claim.h \
$(NULL)
+PARSER_FILES = \
+ parser/parser.c \
+ parser/parser.h \
+ $(NULL)
+
ACLK_FILES = \
aclk/aclk_common.c \
aclk/aclk_common.h \
@@ -597,6 +605,7 @@ NETDATA_FILES = \
$(STATSD_PLUGIN_FILES) \
$(WEB_PLUGIN_FILES) \
$(CLAIM_FILES) \
+ $(PARSER_FILES) \
$(ACLK_FILES) \
$(SPAWN_PLUGIN_FILES) \
$(NULL)