summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorVladimir Kobal <vlad@prokk.net>2020-07-16 15:10:35 +0300
committerGitHub <noreply@github.com>2020-07-16 15:10:35 +0300
commit3e84239ff64ececa6bd54bbddbc9e3d22542dfa9 (patch)
treea86249faf962bec50715e925a432bb07efe3d102 /Makefile.am
parent1b606bc1b2a16dfbcc8b5c7ed780906b482eef11 (diff)
Use the libbpf library for the eBPF plugin (#9490)
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am14
1 files changed, 11 insertions, 3 deletions
diff --git a/Makefile.am b/Makefile.am
index e2d2502304..81a4449052 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -73,6 +73,8 @@ dist_noinst_DATA = \
packaging/bundle-dashboard.sh \
packaging/bundle-mosquitto.sh \
packaging/check-kernel-config.sh \
+ packaging/libbpf.checksums \
+ packaging/libbpf.version \
packaging/ebpf.checksums \
packaging/ebpf.version \
packaging/bundle-lws.sh \
@@ -124,6 +126,7 @@ AM_CFLAGS = \
$(OPTIONAL_IPMIMONITORING_CFLAGS) \
$(OPTIONAL_CUPS_CFLAGS) \
$(OPTIONAL_XENSTAT_CFLAGS) \
+ $(OPTIONAL_BPF_CFLAGS) \
$(NULL)
sbin_PROGRAMS =
@@ -144,8 +147,6 @@ LIBNETDATA_FILES = \
libnetdata/clocks/clocks.h \
libnetdata/dictionary/dictionary.c \
libnetdata/dictionary/dictionary.h \
- libnetdata/ebpf/ebpf.c \
- libnetdata/ebpf/ebpf.h \
libnetdata/eval/eval.c \
libnetdata/eval/eval.h \
libnetdata/inlined.h \
@@ -185,6 +186,13 @@ LIBNETDATA_FILES = \
libnetdata/string/utf8.h \
$(NULL)
+if ENABLE_PLUGIN_EBPF
+ LIBNETDATA_FILES += \
+ libnetdata/ebpf/ebpf.c \
+ libnetdata/ebpf/ebpf.h \
+ $(NULL)
+endif
+
APPS_PLUGIN_FILES = \
collectors/apps.plugin/apps_plugin.c \
$(LIBNETDATA_FILES) \
@@ -665,6 +673,7 @@ endif
NETDATA_COMMON_LIBS = \
$(OPTIONAL_MATH_LIBS) \
+ $(OPTIONAL_BPF_LIBS) \
$(OPTIONAL_ZLIB_LIBS) \
$(OPTIONAL_SSL_LIBS) \
$(OPTIONAL_UUID_LIBS) \
@@ -674,7 +683,6 @@ NETDATA_COMMON_LIBS = \
$(OPTIONAL_JUDY_LIBS) \
$(OPTIONAL_SSL_LIBS) \
$(OPTIONAL_JSONC_LIBS) \
- $(OPTIONAL_EBPF_LIBS) \
$(NULL)
if LINK_STATIC_JSONC