summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorChris Akritidis <43294513+cakrit@users.noreply.github.com>2018-11-12 21:34:59 +0100
committerCosta Tsaousis <costa@tsaousis.gr>2018-11-12 22:34:59 +0200
commit3aae8f6c2ceea7f74cde61a2044aa50c5f252fae (patch)
tree781412f323c0183c520e4ff1c9fdac53a900b463 /Makefile.am
parenta29b433526f56fe983d88dc4e86585bad65916c4 (diff)
Htmldoc (#4607)
* First html documentation debug set * Test 2 * Relative path changed * Updated comments * Cleanup, installation draft added * fixes * test * test * test * First html documentation debug set * Test 2 * Relative path changed * Updated comments * Cleanup, installation draft added * fixes * test * test * test * First set of major cleanup/deduplication * 2nd major cleanup * update getting started structure * Cleanup in using netdata * Final cleanup/deduplication * Added initial CONTRIBUTING.md, updated some info related to contributing on the orchestrators * Removed Why-Netdata (included in new README in master), added link to CONTRIBUTING.md * First html documentation debug set * Updated Makefile.am to ignore the new md and htmldoc generation files * Removing files from rebase * First html documentation debug set * Test 2 * Relative path changed * Updated comments * Cleanup, installation draft added * fixes * test * test * test * First html documentation debug set * Test 2 * Relative path changed * Updated comments * Cleanup, installation draft added * test * test * First set of major cleanup/deduplication * 2nd major cleanup * update getting started structure * Cleanup in using netdata * Final cleanup/deduplication * Added initial CONTRIBUTING.md, updated some info related to contributing on the orchestrators * Removed Why-Netdata (included in new README in master), added link to CONTRIBUTING.md * First html documentation debug set * Updated Makefile.am to ignore the new md and htmldoc generation files * Removing files from rebase * Fixed Makefile.am * Same line header and badges * Fixed broken link * CPU monitoring is in apps plugin * Removed obsolete files * Remove obsolete files * - Make the Health API part of health/README.md new file web/api/health/README.md - Make installer/LAUNCH.md part of deamon/README.md - Move installer/MAINTAINERS.md to packaging/maintainers/README.md - Move installer/DOCKER.md to docker/README.md - Move system/README.md to daemon/config/README.md - Move web/CUSTOM-DASHBOARDS.md to web/gui/custom/README.md - Move web/CONFLUENCE-DASHBOARDS.md to web/gui/confluence/README.md * Resolve codacy issue $(..) syntax instead of `..` * Fix following warnings and add svgs to the data_structures/README.md - CHANGELOG.md - CODE_OF_CONDUCT.md - CONTRIBUTORS.md - REDISTRIBUTED.md - diagrams/data_structures/README.md - docker/README.md WARNING - Documentation file 'README.md' contains a link to 'collectors/plugins.d' which does not exist in the documentation directory. WARNING - Documentation file 'README.md' contains a link to 'collectors/statsd.plugin' which does not exist in the documentation directory. WARNING - Documentation file 'CONTRIBUTING.md' contains a link to 'web/CUSTOM-DASHBOARDS.md' which does not exist in the documentation directory. WARNING - Documentation file 'CONTRIBUTING.md' contains a link to 'web/CONFLUENCE-DASHBOARDS.md' which does not exist in the documentation directory. * Wrong urls in data_structures/README.md svgs * Fix svg URLs number 2 * Modify the first line of the main README.md, to enable proper static html generation. Executed after copying the file to htmldoc/src * Added back Why Netdata * Fixed link to registry in Why-Netdata.md * Added Why-Netdata to buildyaml and to Makefile.am * Replaced http links causing mixed content warnings * Made buildhtml ignore the directory node_modules created by Netlify * Corrected CONTRIBUTING.MD to CONTRIBUTING.md
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am24
1 files changed, 24 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index ddb9a699a1..c90db5ca3c 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -44,6 +44,7 @@ EXTRA_DIST = \
CODE_OF_CONDUCT.md \
LICENSE \
REDISTRIBUTED.md \
+ CONTRIBUTING.md \
$(NULL)
SUBDIRS = \
@@ -61,6 +62,27 @@ dist_noinst_DATA= \
netdata.cppcheck \
netdata.spec \
package.json \
+ doc/Add-more-charts-to-netdata.md \
+ doc/Demo-Sites.md \
+ doc/Donations-netdata-has-received.md \
+ doc/Netdata-Security-and-Disclosure-Information.md \
+ doc/Performance.md \
+ doc/Running-behind-apache.md \
+ doc/Running-behind-caddy.md \
+ doc/Running-behind-lighttpd.md \
+ doc/Running-behind-nginx.md \
+ doc/Third-Party-Plugins.md \
+ doc/a-github-star-is-important.md \
+ doc/high-performance-netdata.md \
+ doc/netdata-for-IoT.md \
+ doc/netdata-security.md \
+ doc/Why-Netdata.md \
+ htmldoc/themes/material/partials/footer.html \
+ installer/README.md \
+ installer/UNINSTALL.md \
+ installer/UPDATE.md \
+ requirements.txt \
+ runtime.txt \
$(NULL)
# until integrated within build
@@ -71,6 +93,8 @@ dist_noinst_SCRIPTS= \
kickstart-static64.sh \
netdata-installer.sh \
installer/functions.sh \
+ htmldoc/buildhtml.sh \
+ htmldoc/buildyaml.sh \
$(NULL)
# -----------------------------------------------------------------------------