summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorVladimir Kobal <vlad@prokk.net>2020-03-30 09:54:39 +0300
committerGitHub <noreply@github.com>2020-03-30 09:54:39 +0300
commit36c2e1dbf3d415880d5e5f4ccb4dbf2e882bb8c6 (patch)
tree23e89e26ee283efb3e2a07c2f6d4d85f69d98ecd /Makefile.am
parentd5d1865469b63385d70645f710728482aed0f23d (diff)
Add a MongoDB connector to the exporting engine (#8416)
* Copy files from the MongoDB backend * Update the documentation * Rename functions in the MongoDB backend * Add the connector to the Netdata build * Add an initializer and a worker * Add specific configuration options * Initialize the connector * Add a ring buffer for inserting data to a MongoDB database * Add unit tests
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am27
1 files changed, 27 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 6fdbca2921..76b6a9348e 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -519,6 +519,11 @@ KINESIS_EXPORTING_FILES = \
exporting/aws_kinesis/aws_kinesis_put_record.h \
$(NULL)
+MONGODB_EXPORTING_FILES = \
+ exporting/mongodb/mongodb.c \
+ exporting/mongodb/mongodb.h \
+ $(NULL)
+
KINESIS_BACKEND_FILES = \
backends/aws_kinesis/aws_kinesis.c \
backends/aws_kinesis/aws_kinesis.h \
@@ -765,6 +770,13 @@ exporting/prometheus/remote_write/remote_write.pb.h: exporting/prometheus/remote
endif
+if ENABLE_EXPORTING
+if ENABLE_BACKEND_MONGODB
+ netdata_SOURCES += $(MONGODB_EXPORTING_FILES)
+ netdata_LDADD += $(OPTIONAL_MONGOC_LIBS)
+endif
+endif
+
if ENABLE_BACKEND_MONGODB
netdata_SOURCES += $(MONGODB_BACKEND_FILES)
netdata_LDADD += $(OPTIONAL_MONGOC_LIBS)
@@ -902,4 +914,19 @@ if ENABLE_BACKEND_KINESIS
-Wl,--wrap=kinesis_get_result \
$(NULL)
endif
+if ENABLE_BACKEND_MONGODB
+ exporting_tests_exporting_engine_testdriver_SOURCES += $(MONGODB_EXPORTING_FILES)
+ exporting_tests_exporting_engine_testdriver_LDADD += $(OPTIONAL_MONGOC_LIBS)
+ exporting_tests_exporting_engine_testdriver_LDFLAGS += \
+ -Wl,--wrap=mongoc_init \
+ -Wl,--wrap=mongoc_uri_new_with_error \
+ -Wl,--wrap=mongoc_uri_get_option_as_int32 \
+ -Wl,--wrap=mongoc_uri_set_option_as_int32 \
+ -Wl,--wrap=mongoc_client_new_from_uri \
+ -Wl,--wrap=mongoc_client_set_appname \
+ -Wl,--wrap=mongoc_client_get_collection \
+ -Wl,--wrap=mongoc_uri_destroy \
+ -Wl,--wrap=mongoc_collection_insert_many \
+ $(NULL)
+endif
endif