summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorTimotej S <6674623+underhood@users.noreply.github.com>2023-05-02 17:43:51 +0200
committerGitHub <noreply@github.com>2023-05-02 17:43:51 +0200
commit2a491f7932b21768149a787c8ef94c5b817471aa (patch)
tree2f4884c386d27bd6b79849c8c2ff3ee2f2cb0ae0 /Makefile.am
parentcd5230b596bdc58f5dbdf97fbc0bee0dc6ea56ab (diff)
Add Cancel Pending Request Message (#14953)
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am9
1 files changed, 9 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index fe979cc8d4..7d9abd549c 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -726,6 +726,8 @@ ACLK_FILES = \
aclk/schema-wrappers/context_stream.h \
aclk/schema-wrappers/context.cc \
aclk/schema-wrappers/context.h \
+ aclk/schema-wrappers/agent_cmds.cc \
+ aclk/schema-wrappers/agent_cmds.h \
$(NULL)
noinst_LIBRARIES += libmqttwebsockets.a
@@ -768,6 +770,7 @@ ACLK_PROTO_DEFINITIONS = \
aclk/aclk-schemas/proto/nodeinstance/info/v1/info.proto \
aclk/aclk-schemas/proto/context/v1/context.proto \
aclk/aclk-schemas/proto/context/v1/stream.proto \
+ aclk/aclk-schemas/proto/agent/v1/cmds.proto \
$(NULL)
dist_noinst_DATA += $(ACLK_PROTO_DEFINITIONS)
@@ -792,6 +795,8 @@ ACLK_PROTO_BUILT_FILES = aclk/aclk-schemas/proto/agent/v1/connection.pb.cc \
aclk/aclk-schemas/proto/context/v1/context.pb.h \
aclk/aclk-schemas/proto/context/v1/stream.pb.cc \
aclk/aclk-schemas/proto/context/v1/stream.pb.h \
+ aclk/aclk-schemas/proto/agent/v1/cmds.pb.cc \
+ aclk/aclk-schemas/proto/agent/v1/cmds.pb.h \
$(NULL)
BUILT_SOURCES += $(ACLK_PROTO_BUILT_FILES)
@@ -838,6 +843,10 @@ aclk/aclk-schemas/proto/context/v1/stream.pb.cc \
aclk/aclk-schemas/proto/context/v1/stream.pb.h: aclk/aclk-schemas/proto/context/v1/stream.proto
$(PROTOC) -I=aclk/aclk-schemas --cpp_out=$(builddir)/aclk/aclk-schemas $^
+aclk/aclk-schemas/proto/agent/v1/cmds.pb.cc \
+aclk/aclk-schemas/proto/agent/v1/cmds.pb.h: aclk/aclk-schemas/proto/agent/v1/cmds.proto
+ $(PROTOC) -I=aclk/aclk-schemas --cpp_out=$(builddir)/aclk/aclk-schemas $^
+
endif #ENABLE_ACLK
ACLK_ALWAYS_BUILD_FILES = \