summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorCosta Tsaousis <costa@netdata.cloud>2023-06-26 14:00:59 +0300
committerGitHub <noreply@github.com>2023-06-26 14:00:59 +0300
commit0d61c11b5f4772a4762ede1d8204290b94bb08e7 (patch)
tree49c97d67e0d2a4846a4b379345f53ef8d93a6aec /Makefile.am
parentf90d56f18d29c2835bc278f6a22e840230b9ca86 (diff)
use gperf for the pluginsd/streaming parser hashtable (#15251)
* use gperf for the pluginsd parser * simplify pluginsd_parser by removing void pointers to user * pluginsd_split_words() with inlined pluginsd_space() * quoted_string_splitter() now uses a map instead of a function for determining spaces * add stress test for pluginsd parser * optimized BITMAP256 * optimized rrdpush receiver reception * optimized rrdpush sender compression * renames and cleanup * remove wrong negation * unify handshake and disconnection reasons * use parser_find_keyword * register job names only for the current repertoire
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am3
1 files changed, 1 insertions, 2 deletions
diff --git a/Makefile.am b/Makefile.am
index 510fbb3e55..2a656eb420 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -168,8 +168,6 @@ LIBNETDATA_FILES = \
libnetdata/log/log.h \
libnetdata/onewayalloc/onewayalloc.c \
libnetdata/onewayalloc/onewayalloc.h \
- libnetdata/parser/parser.c \
- libnetdata/parser/parser.h \
libnetdata/popen/popen.c \
libnetdata/popen/popen.h \
libnetdata/procfile/procfile.c \
@@ -425,6 +423,7 @@ PLUGINSD_PLUGIN_FILES = \
collectors/plugins.d/plugins_d.h \
collectors/plugins.d/pluginsd_parser.c \
collectors/plugins.d/pluginsd_parser.h \
+ collectors/plugins.d/gperf-hashtable.h \
$(NULL)
RRD_PLUGIN_FILES = \