summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorAustin S. Hemmelgarn <austin@netdata.cloud>2024-05-10 10:32:10 -0400
committerGitHub <noreply@github.com>2024-05-10 10:32:10 -0400
commitf8ed61efe10d0c359d7d5f73110853ce3546d2ed (patch)
tree0326688a9b73d2faf5db4d37ce8fd6d91109ad99 /CMakeLists.txt
parentd42b9c6d64be80ec77472e40276ab2f590374fa0 (diff)
Add Sentry support to new CPack packages. (#17627)
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt6
1 files changed, 6 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 1e1e7703fa..c73293a3a2 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -49,6 +49,12 @@ endif()
set(NETDATA_VERSION ${FIELD_MAJOR}.${FIELD_MINOR}.${FIELD_PATCH}.${FIELD_TWEAK})
+if(FIELD_DESCR STREQUAL "N/A")
+ set(CPACK_PACKAGE_VERSION ${FIELD_MAJOR}.${FIELD_MINOR}.${FIELD_PATCH})
+else()
+ set(CPACK_PACKAGE_VERSION ${FIELD_MAJOR}.${FIELD_MINOR}.${FIELD_PATCH}-${FIELD_TWEAK}-${FIELD_DESCR})
+endif()
+
#
# project
#