summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorthiagoftsm <thiagoftsm@gmail.com>2020-05-28 15:47:12 +0000
committerGitHub <noreply@github.com>2020-05-28 15:47:12 +0000
commit9f25a1ca2fbf1edc03fab629ef4746bcf3858d37 (patch)
tree892ea390ab09b674d05393b4e16ec9eab9fc3f7d /CMakeLists.txt
parent6976ddca60dee93d3dcd95c022df5ae9158910b8 (diff)
eBPF modular (#9148)
Convert the monolithic ebpf.plugin in a modular plugin.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt5
1 files changed, 5 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 8fc9190b0a..90581fefd5 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -426,6 +426,11 @@ set(SLABINFO_PLUGIN_FILES
set(EBPF_PROCESS_PLUGIN_FILES
collectors/ebpf.plugin/ebpf.c
+ collectors/ebpf.plugin/ebpf.h
+ collectors/ebpf.plugin/ebpf_process.c
+ collectors/ebpf.plugin/ebpf_process.h
+ collectors/ebpf.plugin/ebpf_socket.c
+ collectors/ebpf.plugin/ebpf_socket.h
)
set(PROC_PLUGIN_FILES