summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorCosta Tsaousis <costa@netdata.cloud>2024-01-29 09:18:01 +0200
committerGitHub <noreply@github.com>2024-01-29 09:18:01 +0200
commit84474006d4cf9eb78a47a3bdffbbedb3964f0068 (patch)
tree6abf1999d02a75c20ee18ce10b91b457df01fe77 /CMakeLists.txt
parent6fe7cfc0e096ce4dd1c2aa2f5ace8752bffdab44 (diff)
New Permissions System (#16837)
* wip of migrating to bitmap permissions * replace role with bitmapped permissions * formatting permissions using macros * accept view and edit permissions for all dynamic configuration * work on older compilers * parse the header in hex * agreed permissions updates * map permissions to old roles * new permissions management * fix function rename * build libdatachannel when enabled - currently for code maintainance * dyncfg now keeps 2 sets of statuses, to keep track of what happens to dyncfg and what actually happens with the plugin * complete the additions of jobs and solve unittests * fix renumbering of ACL bits * processes function shows the cmdline based on permissions and the presence of the sensitive data permission * now the agent returns 412 when authorization is missing, 403 when authorization exists but permissions are not enough, 451 when access control list prevents the user from accessing the dashboard * enable cmdline on processes with thhe HTTP_ACCESS_VIEW_AGENT_CONFIG permission * by default functions require anonymous-data access * fix compilation on debian * fix left-over renamed define * updated schema for alerts * updated permissions * require a name when loading json payloads, if the name is not provided by dyncfg
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt22
1 files changed, 22 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index cad800a0a4..a0b2a0a5a6 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -114,6 +114,27 @@ option(ENABLE_BUNDLED_PROTOBUF "enable bundled protobuf" False)
option(ENABLE_LOGS_MANAGEMENT_TESTS "enable logs management tests" True)
+option(ENABLE_WEBRTC "enable webrtc" False)
+
+if(ENABLE_WEBRTC)
+ include(FetchContent)
+
+ # ignore debhelper
+ set(FETCHCONTENT_FULLY_DISCONNECTED Off)
+
+ set(PREFER_SYSTEM_LIB True)
+ set(NO_MEDIA True)
+ set(NO_WEBSOCKET True)
+
+ set(HAVE_LIBDATACHANNEL True)
+
+ FetchContent_Declare(libdatachannel
+ GIT_REPOSITORY https://github.com/paullouisageneau/libdatachannel.git
+ GIT_TAG v0.20.1
+ )
+ FetchContent_MakeAvailable(libdatachannel)
+endif()
+
#
# handling of extra compiler flags
#
@@ -2010,6 +2031,7 @@ target_link_libraries(netdata PRIVATE
"$<$<BOOL:${ENABLE_EXPORTER_MONGODB}>:${MONGOC_LIBRARIES}>"
"$<$<BOOL:${ENABLE_EXPORTER_PROMETHEUS_REMOTE_WRITE}>:${SNAPPY_LIBRARIES}>"
"$<$<BOOL:${MACOS}>:${IOKIT};${FOUNDATION}>"
+ "$<$<BOOL:${ENABLE_WEBRTC}>:LibDataChannel::LibDataChannelStatic>"
)
#