summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorCosta Tsaousis <costa@tsaousis.gr>2018-10-27 19:44:27 +0300
committerGitHub <noreply@github.com>2018-10-27 19:44:27 +0300
commit798c141c49ee85bddc8f48f25d2cb593ec96da07 (patch)
tree61daf51c5c18f625ca2541b9abe762ad27f13b85 /CMakeLists.txt
parentbcdfedbe8215fdf461b61900eba2a9de4be6c0b8 (diff)
Split the API formatters in modules (#4504)
* split all API formatters in modules * added markdown formatting * updated csv readme * updated csv readme * more documentation * added more documentation * updated documentation * fixed typo * fixed typo
Diffstat (limited to 'CMakeLists.txt')
-rwxr-xr-xCMakeLists.txt18
1 files changed, 16 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 80e759760a..cc28f732ac 100755
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -363,8 +363,6 @@ set(WEB_PLUGIN_FILES
)
set(API_PLUGIN_FILES
- web/api/rrd2json.c
- web/api/rrd2json.h
web/api/web_api_v1.c
web/api/web_api_v1.h
web/api/badges/web_buffer_svg.c
@@ -395,6 +393,22 @@ set(API_PLUGIN_FILES
web/api/queries/ses/ses.h
web/api/queries/des/des.c
web/api/queries/des/des.h
+ web/api/formatters/rrd2json.c
+ web/api/formatters/rrd2json.h
+ web/api/formatters/csv/csv.c
+ web/api/formatters/csv/csv.h
+ web/api/formatters/json/json.c
+ web/api/formatters/json/json.h
+ web/api/formatters/ssv/ssv.c
+ web/api/formatters/ssv/ssv.h
+ web/api/formatters/value/value.c
+ web/api/formatters/value/value.h
+ web/api/formatters/json_wrapper.c
+ web/api/formatters/json_wrapper.h
+ web/api/formatters/charts2json.c
+ web/api/formatters/charts2json.h
+ web/api/formatters/rrdset2json.c
+ web/api/formatters/rrdset2json.h
)
set(STREAMING_PLUGIN_FILES