summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorTimotej S <6674623+underhood@users.noreply.github.com>2020-07-14 17:53:41 +0200
committerGitHub <noreply@github.com>2020-07-14 17:53:41 +0200
commit4732d30e9545b6d3e56822f156a8f0218126fb2f (patch)
treece09437f6200f0e93c0c960a450ef503b06f8e12 /CMakeLists.txt
parent790d19760537cf43348de8db2322a15ced2511cc (diff)
Fixes cmake build failing if ACLK is disabled (#9537)
* if we build claiming we must build aclk_common.c/h * Run unit tests on cmake config changes. Co-authored-by: Austin S. Hemmelgarn <austin@netdata.cloud>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt4
1 files changed, 2 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 6b895d77e9..8b909c24b3 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -658,11 +658,11 @@ set(BACKENDS_PLUGIN_FILES
set(CLAIM_PLUGIN_FILES
claim/claim.c
claim/claim.h
+ aclk/aclk_common.c
+ aclk/aclk_common.h
)
set(ACLK_PLUGIN_FILES
- aclk/aclk_common.c
- aclk/aclk_common.h
aclk/agent_cloud_link.c
aclk/agent_cloud_link.h
aclk/aclk_query.c