summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorCosta Tsaousis <costa@tsaousis.gr>2016-06-19 20:15:15 +0300
committerCosta Tsaousis <costa@tsaousis.gr>2016-06-19 20:15:15 +0300
commit42873e0daaae421b04f8b159cbbeed41330b76e3 (patch)
treed80bd084622d8a2dc4484628d8f90140f66ce662 /CMakeLists.txt
parent06dfb108d389f8dc02a96cc6595f6e124b6da105 (diff)
update cmake configuration
Diffstat (limited to 'CMakeLists.txt')
-rwxr-xr-xCMakeLists.txt12
1 files changed, 6 insertions, 6 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 30ec26a9cc..28c25532c8 100755
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -7,7 +7,7 @@ project(netdata C)
find_package (Threads)
-set(CMAKE_C_FLAGS "${CMAKE_C_FLAGS} -Wall -Wextra -Wformat-signedness")
+set(CMAKE_C_FLAGS "${CMAKE_C_FLAGS} -Wall -Wextra -Wformat-signedness -Werror=format-security")
set(NETDATA_SOURCE_FILES
src/appconfig.c
@@ -54,8 +54,8 @@ set(NETDATA_SOURCE_FILES
src/proc_net_snmp.c
src/proc_net_stat_conntrack.c
src/proc_net_stat_synproxy.c
- src/proc_self_mountinfo.c
- src/proc_self_mountinfo.h
+ src/proc_self_mountinfo.c
+ src/proc_self_mountinfo.h
src/proc_softirqs.c
src/proc_stat.c
src/proc_sys_kernel_random_entropy_avail.c
@@ -77,7 +77,7 @@ set(NETDATA_SOURCE_FILES
src/web_buffer.c
src/web_buffer.h
src/web_buffer_svg.c
- src/web_buffer_svg.h
+ src/web_buffer_svg.h
src/web_client.c
src/web_client.h
src/web_server.c
@@ -98,8 +98,8 @@ set(APPS_PLUGIN_SOURCE_FILES
src/procfile.h
src/storage_number.c
src/storage_number.h
- src/web_buffer.c
- src/web_buffer.h
+ src/web_buffer.c
+ src/web_buffer.h
config.h)
include_directories(AFTER .)