summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorCosta Tsaousis <costa@netdata.cloud>2024-02-02 02:33:31 +0200
committerGitHub <noreply@github.com>2024-02-02 00:33:31 +0000
commit2a4dd3252615197dd8db4ba85b48d222e32c1b27 (patch)
tree1ceb0fe4bcee4812dfeb7921f5f4d6388ac4efcd /CMakeLists.txt
parente2191d90090f3b338e1e77f6f668ca16a7ff53d9 (diff)
Network viewer: filter by username (#16911)
* add users to network-connections function * cleaner and simpler filters; removed IPs and ports, added serverPort
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt7
1 files changed, 5 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 72d27c4a77..ee24a1e202 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -1104,6 +1104,8 @@ set(SYSTEMD_JOURNAL_PLUGIN_FILES
collectors/systemd-journal.plugin/systemd-journal-fstat.c
collectors/systemd-journal.plugin/systemd-journal-watcher.c
collectors/systemd-journal.plugin/systemd-journal-dyncfg.c
+ src/libnetdata/maps/system-users.h
+ src/libnetdata/maps/system-groups.h
)
set(STREAMING_PLUGIN_FILES
@@ -1984,7 +1986,7 @@ endif()
if(ENABLE_PLUGIN_LOCAL_LISTENERS)
set(LOCAL_LISTENERS_FILES
collectors/plugins.d/local_listeners.c
- collectors/plugins.d/local-sockets.h
+ src/libnetdata/maps/local-sockets.h
)
add_executable(local-listeners ${LOCAL_LISTENERS_FILES})
@@ -2003,7 +2005,8 @@ endif()
if(ENABLE_PLUGIN_NETWORK_VIEWER)
set(NETWORK_VIEWER_FILES
- collectors/plugins.d/local-sockets.h
+ src/libnetdata/maps/local-sockets.h
+ src/libnetdata/maps/system-users.h
collectors/network-viewer.plugin/network-viewer.c
)