summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorAustin S. Hemmelgarn <austin@netdata.cloud>2024-02-14 07:01:52 -0500
committerGitHub <noreply@github.com>2024-02-14 07:01:52 -0500
commit12306a3e05ba5778447c26f2e80a4c71da5bee0c (patch)
treec25df4359ed40c8fe43b6b3a12b1c90ba85615c8 /CMakeLists.txt
parent2d64790f8c6c8be091ae6a68a64ba7176096681a (diff)
Assorted cleanup of CI/packaging related code. (#16938)
* Drop unused Dockerfile.test. It’s not been used for years, and it doesn’t even work at this point for it’s intended purpose. * Remove CodeClimate configuration. We’re not using it anymore, so there is no point to keeping the configuration around. * Remove the build_external directory. This isn’t used by any of our code AFAICT, and if it _is_ needed, it should actually be in some sub-directory of `tests` instead of a top-level directory whose name doesn’t even describe what it does. * Remove .gitattributes If there's any objection we can reinstate it. * Move coverity-scan.sh under packaging/utils * Move cmake files under packaging/cmake * Remove devcontainer * Fix up coverity script to run correctly from new location. --------- Co-authored-by: vkalintiris <vasilis@netdata.cloud>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt4
1 files changed, 2 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 6945ebdc71..ef9f438587 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -1522,7 +1522,7 @@ set_source_files_properties(JudyLTables.c PROPERTIES COMPILE_OPTIONS "-I${CMAKE_
# build libnetdata
#
-include(systemd.cmake)
+include(packaging/cmake/systemd.cmake)
add_library(libnetdata STATIC ${LIBNETDATA_FILES})
@@ -2229,7 +2229,7 @@ if (NOT NETDATA_USER)
endif()
set(VERSION "${GIT_DESCRIBE_OUTPUT}")
-configure_file(config.cmake.h.in config.h)
+configure_file(packaging/cmake/config.cmake.h.in config.h)
#
# install