summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorAustin S. Hemmelgarn <austin@netdata.cloud>2024-05-01 11:13:43 -0400
committerGitHub <noreply@github.com>2024-05-01 11:13:43 -0400
commit0f2a261839d5ffc42f17383b4292673aa93d6a1f (patch)
tree3132af02ca40bf02c3bda3486d90de81c091b933 /CMakeLists.txt
parent5007a4ebcced3b270fb5addc14111bbcfe211cb2 (diff)
Fix handling of netdata.conf on install in build system. (#17572)
* Fix handling of netdata.conf on install in build system. * Fix RPM build handling. * Update netdata.spec.in --------- Co-authored-by: Ilya Mashchenko <ilya@netdata.cloud>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt14
1 files changed, 8 insertions, 6 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index c0b8d1f77e..fb962c07f7 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -2523,20 +2523,22 @@ install(FILES
COMPONENT netdata
DESTINATION etc/netdata)
-install(FILES
- system/netdata-updater.conf
- COMPONENT netdata
- DESTINATION etc/netdata)
-
install(PROGRAMS
system/edit-config
COMPONENT netdata
DESTINATION etc/netdata)
+if(BUILD_FOR_PACKAGING)
+ set(NETDATA_CONF_DEST "etc/netdata")
+else()
+ set(NETDATA_CONF_DEST "usr/lib/netdata/conf.d")
+endif()
+
install(FILES
system/netdata.conf
+ system/netdata-updater.conf
COMPONENT netdata
- DESTINATION etc/netdata)
+ DESTINATION ${NETDATA_CONF_DEST})
#
# misc files