summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorChris Akritidis <43294513+cakrit@users.noreply.github.com>2019-01-15 12:49:28 +0100
committerGitHub <noreply@github.com>2019-01-15 12:49:28 +0100
commit08649bec373555144878b4314e87c9a8eb38c82e (patch)
tree23c9246e606f948944af8bc33f976085fa455848 /CMakeLists.txt
parent67834f184ff3d67f6c8b6005ac68b568d7573118 (diff)
Port ACLs, Management API and Health commands (#4969)
##### Summary fixes #2673 fixes #2149 fixes #5017 fixes #3830 fixes #3187 fixes #5154 Implements a command API for health which will accept commands via a socket to selectively suppress health checks. Allows different ports to accept different request types (streaming, dashboard, api, registry, netdata.conf, badges, management) Removes support for multi-threaded and single-threaded web servers. ##### Component Name health, daemon
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt16
1 files changed, 6 insertions, 10 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 1c3d207596..cb1e1ef482 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -13,7 +13,7 @@ find_package(PkgConfig REQUIRED)
#set(CMAKE_BUILD_TYPE "Release")
# set this to see the compilation commands
-#set(CMAKE_VERBOSE_MAKEFILE 1)
+# set(CMAKE_VERBOSE_MAKEFILE 1)
# -----------------------------------------------------------------------------
@@ -30,8 +30,8 @@ IF("${CMAKE_BUILD_TYPE}" MATCHES "Debug")
set(CXX_FORMAT_SIGNEDNESS "-Wformat-signedness")
set(CXX_FORMAT_SECURITY "-Werror=format-security")
set(CXX_STACK_PROTECTOR "-fstack-protector-all")
-
- set(CMAKE_C_FLAGS "${CMAKE_C_FLAGS} -O1 -ggdb -Wall -Wextra -DNETDATA_INTERNAL_CHECKS=1 -DNETDATA_VERIFY_LOCKS=1 ${CXX_FORMAT_SIGNEDNESS} ${CXX_FORMAT_SECURITY} ${CXX_STACK_PROTECTOR}")
+ set(CXX_FLAGS_DEBUG "-O0")
+ set(CMAKE_C_FLAGS "${CMAKE_C_FLAGS} -O1 -ggdb -Wall -Wextra -DNETDATA_INTERNAL_CHECKS=1 -DNETDATA_VERIFY_LOCKS=1 ${CXX_FORMAT_SIGNEDNESS} ${CXX_FORMAT_SECURITY} ${CXX_STACK_PROTECTOR} ${CXX_FLAGS_DEBUG}")
ELSE()
message(STATUS "building for: release")
cmake_policy(SET CMP0069 "NEW")
@@ -221,8 +221,7 @@ set(HEALTH_PLUGIN_FILES
health/health.h
health/health_config.c
health/health_json.c
- health/health_log.c
- )
+ health/health_log.c)
set(IDLEJITTER_PLUGIN_FILES
collectors/idlejitter.plugin/plugin_idlejitter.c
@@ -354,10 +353,6 @@ set(WEB_PLUGIN_FILES
web/server/web_client.h
web/server/web_server.c
web/server/web_server.h
- web/server/single/single-threaded.c
- web/server/single/single-threaded.h
- web/server/multi/multi-threaded.c
- web/server/multi/multi-threaded.h
web/server/static/static-threaded.c
web/server/static/static-threaded.h
web/server/web_client_cache.c
@@ -411,6 +406,7 @@ set(API_PLUGIN_FILES
web/api/formatters/charts2json.h
web/api/formatters/rrdset2json.c
web/api/formatters/rrdset2json.h
+ web/api/health/health_cmdapi.c
)
set(STREAMING_PLUGIN_FILES
@@ -479,7 +475,7 @@ add_definitions(
-DLIBCONFIG_DIR="/usr/lib/netdata/conf.d"
-DLOG_DIR="/var/log/netdata"
-DPLUGINS_DIR="/usr/libexec/netdata"
- -DWEB_DIR="/usr/share/netdata"
+ -DWEB_DIR="/usr/share/netdata/web"
-DVARLIB_DIR="/var/lib/netdata"
)