summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
author0x501D <mail@void.so>2021-05-30 00:33:14 +0300
committer0x501D <mail@void.so>2021-05-30 00:33:14 +0300
commite48198557519ea684f20dba36bf45a60664ee638 (patch)
treeb8c10d07067b049587aae298c7118a4ff809d437 /CMakeLists.txt
parentd6a5cdb8cb11706c8076d92f5191119928d5be4c (diff)
build: fix ld errors and clang warnings of FreeBSD
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt4
1 files changed, 2 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 99788e1..43038ca 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -1,4 +1,4 @@
-cmake_minimum_required(VERSION 2.8)
+cmake_minimum_required(VERSION 2.8.12)
project(nemu C)
@@ -96,7 +96,7 @@ find_package(UDev REQUIRED)
pkg_check_modules(JSONC REQUIRED json-c)
target_link_libraries(
- ${PROJECT_NAME} ${CURSES_LIBRARIES} ${SQLITE3_LIBRARIES} ${JSONC_LIBRARIES}
+ ${PROJECT_NAME} ${CURSES_LIBRARIES} ${SQLITE3_LIBRARIES} ${JSONC_LINK_LIBRARIES}
${CMAKE_THREAD_LIBS_INIT} ${LIBUSB_1_LIBRARIES} ${UDEV_LIBRARIES}
${RT_LIBRARY})
include_directories(${CURSES_INCLUDE_PATH} ${SQLITE3_INCLUDE_DIR}