summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorPavel Balaev <mail@void.so>2019-12-05 17:03:16 +0300
committerPavel Balaev <mail@void.so>2019-12-05 17:03:16 +0300
commita522cdfc35e7b88d9e89c491ef2bb5b90838141a (patch)
tree7cc4ced5d3e9e82f7733cb4b8ffde7f5030ea626 /CMakeLists.txt
parent31073b2630740bb503a894483da450c97ec52db0 (diff)
build: add -Wformat-security
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index f5cba80..459ff77 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -163,7 +163,7 @@ add_custom_target(uninstall
include(CheckCCompilerFlag)
CHECK_C_COMPILER_FLAG("-std=c99" COMPILER_SUPPORTS_C99)
set_property(TARGET ${PROJECT_NAME} APPEND_STRING PROPERTY COMPILE_FLAGS
- "-Wall -Wextra -pedantic -isystem ${LIBUSB_1_INCLUDE_DIRS} ")
+ "-Wall -Wextra -Wformat-security -pedantic -isystem ${LIBUSB_1_INCLUDE_DIRS} ")
if(COMPILER_SUPPORTS_C99)
set_property(TARGET ${PROJECT_NAME} APPEND_STRING PROPERTY COMPILE_FLAGS "-std=c99")