summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorVoid <mail@void.so>2020-01-31 18:05:31 +0300
committerVoid <mail@void.so>2020-01-31 18:05:31 +0300
commit2277deb5fba72da31f62b1ea683dd1021349d17e (patch)
tree96bff2ed2c02449717e52e7d1142fcc3342492f5 /CMakeLists.txt
parentb39c685cf7dc4aefa68a85662a2cdd3ac4c5aaf6 (diff)
net: setup interface altnames (closes #23)
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt8
1 files changed, 8 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 459ff77..2dd06d2 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -1,3 +1,4 @@
+include(CheckSymbolExists)
cmake_minimum_required(VERSION 2.8)
project(nemu C)
set(CMAKE_COLOR_MAKEFILE OFF)
@@ -48,6 +49,13 @@ if (NM_WITH_NETWORK_MAP)
add_definitions(-DNM_WITH_NETWORK_MAP)
endif()
+if (CMAKE_SYSTEM_NAME STREQUAL Linux)
+ check_symbol_exists(RTM_NEWLINKPROP "linux/rtnetlink.h" HAVE_NEWLINKPROP)
+ if (HAVE_NEWLINKPROP)
+ add_definitions(-DNM_WITH_NEWLINKPROP)
+ endif()
+endif()
+
set(CURSES_NEED_NCURSES TRUE)
set(CURSES_NEED_WIDE TRUE)
find_package(Curses REQUIRED)