summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorBoris Stepanenko <Boris.Stepanenko@gmail.com>2021-08-26 17:18:00 +0300
committerBoris Stepanenko <Boris.Stepanenko@gmail.com>2021-08-26 17:18:00 +0300
commit13d63eec3eb0fa1e02b6bc9e6d98529205cc9cfe (patch)
tree475c0e22675015f3773e93251a2b23d91530078d /CMakeLists.txt
parentce55ce606566498cbde57b8dc0e06ccc773c69df (diff)
Revert "cmake: require RT only for linux with glibc older than 2.17"
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt5
1 files changed, 1 insertions, 4 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 30cd845..5b9a927 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -104,6 +104,7 @@ endif()
find_package(Sqlite3 REQUIRED)
find_package(Threads REQUIRED)
+find_package(RT REQUIRED)
find_package(libusb-1.0 REQUIRED)
find_package(UDev REQUIRED)
pkg_check_modules(JSONC REQUIRED json-c)
@@ -160,10 +161,6 @@ if(NM_OS_LINUX)
add_definitions(-DNM_WITH_SENDFILE)
endif()
- if(GLIBC_VERSION VERSION_LESS 2.17)
- find_package(RT REQUIRED)
- endif()
-
if(NM_CUSTOM_SYS_INCLUDE)
check_symbol_exists(
RTM_NEWLINKPROP "${NM_CUSTOM_SYS_INCLUDE}/linux/rtnetlink.h"