summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorThomas Roessler <roessler@does-not-exist.org>1999-06-08 18:30:42 +0000
committerThomas Roessler <roessler@does-not-exist.org>1999-06-08 18:30:42 +0000
commit9b47f0be31e3ca3c48146893048efefdb22aaf75 (patch)
treeaefb4a2eb5c88bfe90f4d68306ec7638f2c1a7d4 /configure.in
parent8d759499d955cbe63ba49103cf798dfc9460d247 (diff)
Portability patches for SunOS 4.1. From Lars Hecking.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in26
1 files changed, 24 insertions, 2 deletions
diff --git a/configure.in b/configure.in
index 2a4ce27c..556140fb 100644
--- a/configure.in
+++ b/configure.in
@@ -202,10 +202,15 @@ main ()
AC_HEADER_STDC
-AC_CHECK_HEADERS(stdarg.h sys/ioctl.h sysexits.h getopt.h)
+AC_CHECK_HEADERS(stdarg.h sys/ioctl.h sysexits.h)
AC_TYPE_SIGNAL
+AC_MSG_CHECKING(for sig_atomic_t in signal.h)
+AC_EGREP_HEADER(sig_atomic_t,signal.h,dnl
+ [ ac_cv_type_sig_atomic_t=yes; AC_MSG_RESULT(yes) ],dnl
+ AC_MSG_RESULT(no); AC_CHECK_TYPE(sig_atomic_t, int))
+
AC_DECL_SYS_SIGLIST
dnl need this for DEC alpha
@@ -213,10 +218,27 @@ AC_CHECK_SIZEOF(long)
AC_TYPE_PID_T
-AC_CHECK_FUNCS(setegid srand48 strerror)
+AC_CHECK_FUNCS(fgetpos memmove setegid srand48 strerror)
AC_REPLACE_FUNCS(strcasecmp)
+AC_CHECK_FUNC(getopt)
+if test $ac_cv_func_getopt = yes; then
+ AC_CHECK_HEADERS(getopt.h)
+ if test $ac_cv_header_getopt_h = no; then
+ AC_MSG_CHECKING(for getopt declaration in stdio.h)
+ AC_EGREP_HEADER(getopt,stdio.h,dnl
+ [ AC_DEFINE(HAVE_GETOPT_DECL)
+ AC_MSG_RESULT(yes) ],dnl
+ AC_MSG_RESULT(no)
+ AC_MSG_CHECKING(for getopt declaration in stdlib.h)
+ AC_EGREP_HEADER(getopt,stdlib.h,dnl
+ [ AC_DEFINE(HAVE_GETOPT_DECL)
+ AC_MSG_RESULT(yes) ],dnl
+ AC_MSG_RESULT(no)))
+ fi
+fi
+
mutt_cv_snprintf=no
SNPRINTFOBJS=""
AC_CHECK_FUNC(snprintf, [AC_DEFINE(HAVE_SNPRINTF)], [mutt_cv_snprintf=yes])