summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorThomas Roessler <roessler@does-not-exist.org>1999-02-18 22:11:27 +0000
committerThomas Roessler <roessler@does-not-exist.org>1999-02-18 22:11:27 +0000
commit9695791fff221ebe1314b7408e4f0f402e0d53af (patch)
tree0bacee419865e30d4bf14f1439cfb9e583c75452 /configure.in
parenta15f31d6be1e72ec7a828be3db98715b9e2abf13 (diff)
Introduce $dotlock_program: This makes the mutt_dotlock program's
location a run-time configuration variable.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in10
1 files changed, 6 insertions, 4 deletions
diff --git a/configure.in b/configure.in
index 58555c26..547771f2 100644
--- a/configure.in
+++ b/configure.in
@@ -318,9 +318,13 @@ int main (int argc, char **argv)
fi
fi
-if test "x$mutt_cv_setgid" = "xyes" || test "x$mutt_cv_fchdir" = "xno"
+AC_ARG_ENABLE(external_dotlock, [ --enable-external-dotlock Force use of an external dotlock program],
+ [mutt_cv_external_dotlock=yes])
+
+if test "x$mutt_cv_setgid" = "xyes" || test "x$mutt_cv_fchdir" = "xno" \
+ || test "x$mutt_cv_external_dotlock" = "xyes"
then
- CPPFLAGS="$CPPFLAGS -DDL_STANDALONE -DDOTLOCK=\"\\\"\$(bindir)/mutt_dotlock\\\"\""
+ AC_DEFINE(DL_STANDALONE)
DOTLOCK_TARGET="mutt_dotlock"
else
MUTT_LIB_OBJECTS="$MUTT_LIB_OBJECTS dotlock.o"
@@ -448,8 +452,6 @@ if test "$ac_cv_prog_CC" = gcc -a $mutt_cv_warnings = yes; then
CFLAGS="-Wall -pedantic $CFLAGS"
fi
-CFLAGS="-DHAVE_CONFIG_H=1 $CFLAGS"
-
AC_ARG_ENABLE(nfs-fix, [ --enable-nfs-fix Work around an NFS with broken attributes caching ],
[if test x$enableval = xyes; then
AC_DEFINE(NFS_ATTRIBUTE_HACK)