summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorThomas Roessler <roessler@does-not-exist.org>1998-10-27 18:59:53 +0000
committerThomas Roessler <roessler@does-not-exist.org>1998-10-27 18:59:53 +0000
commit92416aa5c0cef4c4b1267b7b8abbd359edf882c3 (patch)
tree912a9ab31baddae5c8f46ac70b282aafe897cf7b /configure.in
parent92cdb05854f73b9ea7672a7ab69763b9f3b43b7f (diff)
Try to detect Solaris 2.4's broken regcomp().
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in16
1 files changed, 14 insertions, 2 deletions
diff --git a/configure.in b/configure.in
index bfa67b71..f51d677d 100644
--- a/configure.in
+++ b/configure.in
@@ -212,8 +212,6 @@ AC_CHECK_FUNCS(strftime, break, [AC_CHECK_LIB(intl, strftime)])
dnl AIX may not have fchdir()
AC_CHECK_FUNCS(fchdir, [AC_DEFINE(HAVE_FCHDIR)], [mutt_cv_fchdir=no])
-
-dnl what about this macro? AM_WITH_REGEX
mutt_cv_regex=yes
AC_ARG_WITH(rx, [ --with-rx[=DIR] Use GNU rx ],
[if test $withval != yes; then
@@ -231,6 +229,20 @@ AC_ARG_WITH(rx, [ --with-rx[=DIR] Use GNU rx ],
RX_TARGET=no
+if test $mutt_cv_regex = no ; then
+ AC_MSG_CHECKING(whether your system's regexp library is completely broken)
+ AC_TRY_RUN([
+#include <unistd.h>
+#include <regex.h>
+main() { regex_t blah ; return regcomp(&blah, "foo.*bar", REG_NOSUB) || regexec (&blah, "foobar", 0, NULL, 0); }],
+ mutt_cv_regex_broken=no, mutt_cv_regex_broken=yes)
+ AC_MSG_RESULT([$mutt_cv_regex_broken])
+ if test $mutt_cv_regex_broken = yes ; then
+ echo "Using the included GNU rx instead." >&AC_FD_MSG
+ mutt_cv_regex=yes
+ fi
+fi
+
if test $mutt_cv_regex = yes; then
if test -d ../rx-1.5; then
LIBS="$LIBS ../rx-1.5/rx/librx.a"