summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorThomas Roessler <roessler@does-not-exist.org>1998-06-08 20:05:39 +0000
committerThomas Roessler <roessler@does-not-exist.org>1998-06-08 20:05:39 +0000
commit90bea32a9b22777b4b32e787661aa532c7d77fc2 (patch)
treec440dc034d44d8b7c95073cc80b7a3f3b3b6c219 /configure.in
parent6f8d5623a93d23e714f3252ab1bca02b9fc3bc86 (diff)
GPG support, first take.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in10
1 files changed, 9 insertions, 1 deletions
diff --git a/configure.in b/configure.in
index aa620bbc..7c854686 100644
--- a/configure.in
+++ b/configure.in
@@ -23,6 +23,14 @@ OPS='$(srcdir)/OPS'
if test -f $srcdir/pgp.c; then
SUBVERSION=i
PGPPATH=no
+
+ AC_PATH_PROG(GPG, gpg, no)
+ if test $GPG != no ; then
+ AC_DEFINE_UNQUOTED(_PGPGPGPATH, "$GPG")
+ PGPPATH="$GPG"
+ AC_DEFINE(HAVE_GPG)
+ fi
+
AC_PATH_PROG(PGPK, pgpk, no)
if test $PGPK != no ; then
PGPK=`echo $PGPK | sed 's,.$,,'`
@@ -43,7 +51,7 @@ if test -f $srcdir/pgp.c; then
fi
if test $PGP != no || test $PGPK != no ; then
- LIBOBJS="$LIBOBJS pgp.o pgpinvoke.o pgpkey.o pgppubring.o sha1dgst.o"
+ LIBOBJS="$LIBOBJS pgp.o pgpinvoke.o pgpkey.o pgppubring.o sha1dgst.o gnupgparse.o"
OPS="$OPS \$(srcdir)/OPS.PGP"
fi
fi