summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorThomas Roessler <roessler@does-not-exist.org>1999-01-13 01:53:03 +0000
committerThomas Roessler <roessler@does-not-exist.org>1999-01-13 01:53:03 +0000
commit822535edf4b160d9f023fd2026c824ef061f4ea5 (patch)
treed2bc1f73f47c95b140c4c0ea0be42b70f26880fe /configure.in
parenta983c11963da7df7c9e4a99e54084a2cf4a1b176 (diff)
A first take at adding a mixmaster front-end to mutt. Don't worry,
it's optional. ;-)
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in12
1 files changed, 12 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index 73f522ef..08bbc867 100644
--- a/configure.in
+++ b/configure.in
@@ -80,6 +80,18 @@ else
MUTT_LIB_OBJECTS="$MUTT_LIB_OBJECTS pgp.o pgpinvoke.o pgpkey.o pgppubring.o sha1dgst.o gnupgparse.o"
OPS="$OPS \$(srcdir)/OPS.PGP"
fi
+
+ AC_ARG_WITH(mixmaster, [ --with-mixmaster[=PATH] include Mixmaster support],
+ [if test -x "$withval" ; then
+ MIXMASTER="$withval"
+ else
+ MIXMASTER="mixmaster"
+ fi
+ OPS="$OPS \$(srcdir)/OPS.MIX"
+ MUTT_LIB_OBJECTS="$MUTT_LIB_OBJECTS remailer.o"
+ AC_DEFINE_UNQUOTED(MIXMASTER, "$MIXMASTER")
+ ])
+
fi
AC_SUBST(OPS)